This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes BEA/Weblogic and the fly likes Please any body help me, help me,help me!!!!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Please any body help me, help me,help me!!!!!" Watch "Please any body help me, help me,help me!!!!!" New topic
Author

Please any body help me, help me,help me!!!!!

Aaron Buch
Greenhorn

Joined: Oct 23, 2000
Posts: 17
When i try to start the Weblogic from VisualCafe i am getting a pop up message as
Server directory not specified in WebLogic options.
unable to start server.
and at the bottom in VisualCafe iam getting a message as
Can't find class weblogic/ejbc
.jar Processing Failed!
Iam using Weblogic server 5.1 on WindowsNT and using WebGain's VisualCaf� Enterprise Edition 4.0 .
Look forward for your reply.
George Brown
Ranch Hand

Joined: Sep 26, 2000
Posts: 919
Hi Aaron
Load up your Project, and there should be a menu called 'Tools'. From that menu choose the option 'Environment Options...' to bring up a tabbed dialog box. Choose the UML/EJB tab and make sure that at the bottom of that your Deployment Target is set to WebLogic Server 5.1
When it is, select 'Manage Deployment Target' and you are given a 'property/value' list. Make sure that the values are correctly set according to your machine setup.
I hope that helps.
George
Aaron Buch
Greenhorn

Joined: Oct 23, 2000
Posts: 17
George,
I loaded up my Project and i selected menu called 'Tools' and then chosen Environment Options, got tabbed dialog box. I chosen the UML/EJB tab and at the bottom Deployment Target is already set to WebLogic Server 5.1.
I selected Manage Deployment Target and got 'property/value' list.
In that all values are set correctly .
property value
Javac executable(for ejbc) d:\VisualCafeEE\java2\bin\javac.exe
But still iam getting the same error message.
Please help me!!!
Aaron Buch
Greenhorn

Joined: Oct 23, 2000
Posts: 17
Please i request anybody to answer this Question?
Aaron Buch
Greenhorn

Joined: Oct 23, 2000
Posts: 17
I kindly request anybody to answer this question.
George Brown
Ranch Hand

Joined: Sep 26, 2000
Posts: 919
Aaron, it is most likely a problem with your CLASSPATH. Check that your CLASSPATH is set up correctly to run WebLogic independently, from the command line for example (not from within Visual Cafe). Then when you are sure that it is working correctly, and your system has the correct CLASSPATH, start up Visual Cafe, and your CLASSPATH should then be set up ok to run WebLogic. To get more information on how to do this, you can look at the script files that come with WebLogic Server, they show what CLASSPATH settings are required ('startWebLogic.cmd' for Windows NT, 'startWebLogic.sh' for UNIX).
It is not just the 'Javac executable(for ejbc)' that you need to check is ok in the property/value list. There is more likely to be a problem with the Server directory, or the CLASSPATH settings.
Without knowing the individual setup of your machine and programs, it is very difficult for anyone to be more specific.
Aaron Buch
Greenhorn

Joined: Oct 23, 2000
Posts: 17
George,
Iam running WindowsNT .
So i went to start->settings->controlpanel->system
so in systemprpoerties i chose Environment.
In Environment there is System Variables and User Variables.
In userVariables the CLASSPATH is set to
D:\jdk1.3\bin;d:\VisualCafeEE\Java\Lib;d:\VisualCafeEE\Java\Lib\SYMCLASS.ZIP;d:\VisualCafeEE\Java\Lib\CLASSES.ZIP;d:\VisualCafeEE\Java\Lib\COLLECTIONS.ZIP;d:\VisualCafeEE\Java\Lib\ ICEBROWSERBEAN.JAR;d:\VisualCafeEE\Java\Lib\SYMTOOLS.JAR;d:\VisualCafeEE\JFC\SWINGALL.JAR;d:\VisualCafeEE\Bin\Components\SFC.JAR;d:\VisualCafeEE\Bin\Components\SYMBEANS.JAR;d:\Visu alCafeEE\Java\Lib\DBAW.ZIP;d:\VisualCafeEE\Bin\Components\DBAW_AWT.JAR;d:\VisualCafeEE\Bin\Components\Databind.JAR;d:\VisualCafeEE\Java\Lib\ERADTOOLS.JAR;d:\VisualCafeEE\Java\Lib\E RADPUBLIC.JAR;d:\VisualCafeEE\Java\Lib\servlet.jar;d:\VisualCafeEE\Java\Lib\server.jar;d:\VisualCafeEE\Bin\Components\templates.jar;d:\VisualCafeEE\Java\Lib\javax_ejb.ZIP;d:\Visual CafeEE\Java\Lib\jndi.jar;d:\VisualCafeEE\Bin\Components\vcejbwl.jar;d:\VisualCafeEE\Bin\sb;d:\VisualCafeEE\Bin\sb\classes\sb.jar;.;
In Weblogic properties it is set to
# Deploys EJBeans. Uncomment the appropriate lines below and
# modify DBMS-related info and paths to match your particular installation:
#weblogic.ejb.deploy=\
d:/WebLogic/myserver/ejb_basic_beanManaged.jar, \
d:/WebLogic/myserver/ejb_basic_containerManaged.jar, \
d:/WebLogic/myserver/ejb_basic_statefulSession.jar, \
d:/WebLogic/myserver/ejb_basic_statelessSession.jar, \
d:/WebLogic/myserver/ejb_extensions_finderEnumeration.jar, \
d:/WebLogic/myserver/ejb_extensions_readMostly.jar, \
d:/WebLogic/myserver/ejb_subclass.jar, \
d:/WebLogic/myserver/jolt_ejb_bankapp.jar
---------------------------------------------------------------
Do i have to modify the above paths.
---------------------------------------------------------------

# WEBLOGIC JSP PROPERTIES
# ------------------------------------------------
# Sets up automatic page compilation for JSP. Adjust init args for
# directory locations and uncomment to use.
weblogic.httpd.register.*.jsp=\
weblogic.servlet.JSPServlet
weblogic.httpd.initArgs.*.jsp=\
pageCheckSeconds=1,\
compileCommand=D:/VisualCafeEE/Java/bin/javac.exe,\
workingDir=d:/WebLogic/myserver/classfiles,\
verbose=true

Aaron Buch
Greenhorn

Joined: Oct 23, 2000
Posts: 17

In weblogic documentation its said
Specify the following classes in the WebLogic classpath, using the weblogic.class.path property.
weblogic/classes
weblogic/lib/weblogicaux.jar
weblogic/license
weblogic/myserver/serverclasses
I tried to set it in this way
D:\>java -classpath -Dweblogic.class.path=d:/weblogic/classes;d:/weblogic/lib/we
blogicaux.jar;d:/weblogic/license;d:/weblogic/myserver/serverclasses weblogic.server
and then when i hit enter getting error as
Unable to initialize threads: cannot find class java/lang/Thread
ravi janap
Ranch Hand

Joined: Nov 04, 2000
Posts: 389
Originally posted by Aaron Buch:
When i try to start the Weblogic from VisualCafe i am getting a pop up message as
Server directory not specified in WebLogic options.
unable to start server.
and at the bottom in VisualCafe iam getting a message as
Can't find class weblogic/ejbc
.jar Processing Failed!
Iam using Weblogic server 5.1 on WindowsNT and using WebGain's VisualCaf� Enterprise Edition 4.0 .
Look forward for your reply.


Dear Aaron,
in weblogic server.properties file you have to configure weblogic.ejbc to the path where java compiler can be found.
regds
Ravindra


SCJP, SCJD, SCWCD, SCBCD, SCEA
Erin Baron
Greenhorn

Joined: Nov 01, 2000
Posts: 26
Dear Aaron,
Where in weblogic server.properties file i have to configure weblogic.ejbc.
Is it in WEBLOGIC JSP PROPERTIES
There my
compileCommand=d:/jdk1.3/bin/javac.exe,\
At first i gave my compileCommand as compileCommand=D:/VisualCafeEE/Java/bin/javac.exe,\
as this command is not working for JSP's so
later i gave it as compileCommand=d:/jdk1.3/bin/javac.exe,\
to run JSP's.
This problem persits me for a while.
My Probem is:
I downloaded visualCafe Enterprise Edition 4.0(Trial) a 60 day trial from WebGainStudio(Trial).
and weblogic5.1.0 from BEA.
My Problem is:
When i try to Deliver Enterprise Beans to EJB server or execute EJB from Project options in VisualCafe getting an error message at bottom in visualCafe as
Can't find weblogic/ejbc.
.Jar Processing Failed!

Can anybody try to respond it ASAP.

Aaron Buch
Greenhorn

Joined: Oct 23, 2000
Posts: 17
Hey Erin still my problem was not solved.
Bill Bilic
Greenhorn

Joined: Dec 05, 2000
Posts: 1
Aaron,
I don't know whether you found the answer to your question, but what I did (after I got the same error) is:
- go to Tools/Environment Options,
- go to Internal VM
- click New, to add to your Classpath Settings,
- type the patht to your [drive letter]:\weblogic\classes. That is where all classes needed for EJB should be.
- click OK on your way out while closing the tabs and dialogs.
- close Visual Cafe, because you have to restart environment for changes to take effect.
It worked just fine after these changes.
If this does not help, let me know, and we can try something else.
Regards, Bill.
Originally posted by Aaron Buch:
When i try to start the Weblogic from VisualCafe i am getting a pop up message as
Server directory not specified in WebLogic options.
unable to start server.
and at the bottom in VisualCafe iam getting a message as
Can't find class weblogic/ejbc
.jar Processing Failed!
Iam using Weblogic server 5.1 on WindowsNT and using WebGain's VisualCaf� Enterprise Edition 4.0 .
Look forward for your reply.

 
Don't get me started about those stupid light bulbs.
 
subject: Please any body help me, help me,help me!!!!!
 
Similar Threads
Can't find class weblogic/ejbc
How I can deploy ejb on weblogic server6.0??
****** How to use JSP Taglibraries ???
Can't find class weblogic/ejbc
weblogic showing errors when accessing classs from user def jar files