File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes BEA/Weblogic and the fly likes JSP pages not getting updated Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Head First Android this week in the Android forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "JSP pages not getting updated" Watch "JSP pages not getting updated" New topic

JSP pages not getting updated

Mark Kaplun

Joined: Jul 26, 2001
Posts: 4
I just started to play with WebLogic 6. I built sample JSP pages as documentations suggested and was able to invoke them with example server/application.
Now, when I make a changes to jsp page the server doesn't pick up this changes. I have to rebuild the page to see the changes I've made.(I am talking about HTML type of changes). I've done a project with Tomcat and never had this kind of problem.
Any ideas?
Thank you in advance for your help.
Lars Neumann

Joined: Jul 03, 2001
Posts: 11
I have the same problem. You can write this
into your weblogic.xml between the jsp-descriptor tags, and it is supposed to help. but in my case it doesn't. maybe it can help you.
Mark Kaplun

Joined: Jul 26, 2001
Posts: 4
According to documentation the parameter "pageCheckSeconds":
"Sets the interval, in seconds, at which WebLogic Server checks to see if JSP files have changed and need recompiling. Dependencies are also checked and recursively reloaded if changed.
If set to 0, pages are checked on every request. If set to -1, page checking and recompiling is disabled"
I have tried to set to 0 - didn't help neither.
I have uninstalled and installed back to make sure I have clean, original set up. The same result.
Strange, isn't?
Lars Neumann

Joined: Jul 03, 2001
Posts: 11
very strange!
in my case it doesn't work either. not with 1 and not with 0! refreshing the page while pressing the ctrl-key works fine.
I agree. Here's the link:
subject: JSP pages not getting updated
It's not a secret anymore!