Win a copy of Learn Spring Security (video course) this week in the Spring forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

javabeans problem

 
Srinivas Prasad
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to run a jsp with a usebean tag, my jsp file is in the defaultwebserver directory, and my javabean class is in the web-inf/classes directory . i am using wl6.0 and the error i am getting is "jsp compile error , cannot resolve symbol" and it gives the usebean line
<jsp:useBean id="xxxx" class="xxxjava" scope="request" />
I changed the scope to session, and even took it out, but the problem exists. Pls help.
 
Marcos Maia
Ranch Hand
Posts: 977
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
To use beans in WL Server(in the default directories) you have to set up a classpath pointing to your bean class take a look at:
http://e-docs.bea.com/wls/docs60/jsp/reference.html#59070
or you can allways package your application in a war file an than you won�t face this problem.
 
Srinivas Prasad
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the info. How do I create the war file?
Thanks.
 
Marcos Maia
Ranch Hand
Posts: 977
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
you have to use the jar command of jsdk take a look at the jar tutorial at: http://java.sun.com/docs/books/tutorial/jar/index.html
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic