aspose file tools*
The moose likes BEA/Weblogic and the fly likes Cannot view the left frame of admin console Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Cannot view the left frame of admin console" Watch "Cannot view the left frame of admin console" New topic
Author

Cannot view the left frame of admin console

Kodo Tan
Ranch Hand

Joined: Aug 14, 2001
Posts: 105
Hi all
I have the above problem, ie. cannot view the left frame of the admin console. I tried to uninstall and reinstall wls6.1 but still have the same problem.
Anyone knows how to resolve this. Thanks !
Kodo Tan
Ranch Hand

Joined: Aug 14, 2001
Posts: 105
Hi
In addition to my previous problem, I discovered the following error in Netscape Java console. It seemed that I cannot run the applet on the left frame of the admin console. I tried to access some sites with applets and they were okay.
Netscape Communications Corporation -- Java 1.1.5
Type '?' for options.
Symantec Java! ByteCode Compiler Version 210.065
Copyright (C) 1996-97 Symantec Corporation
netscape.security.AppletSecurityException: security.Couldn't connect to '127.0.0.1' with origin from 'local-classpath-classes'.
at java.lang.Throwable.<init>(Compiled Code)
at java.lang.Exception.<init>(Compiled Code)
at java.lang.RuntimeException.<init>(Compiled Code)
at java.lang.SecurityException.<init>(Compiled Code)
at netscape.security.AppletSecurityException.<init>(Compiled Code)
at netscape.security.AppletSecurityException.<init>(Compiled Code)
at netscape.security.AppletSecurity.checkConnect(Compiled Code)
at java.lang.SecurityManager.checkConnect(Compiled Code)
at sun.awt.SunToolkit.getImageFromHash(Compiled Code)
at sun.awt.SunToolkit.getImage(Compiled Code)
* at weblogic.management.console.applets.ImageCatalog.fetch(Compiled Code)
at weblogic.management.console.applets.NavApplet.init(Compiled Code)
at netscape.applet.DerivedAppletFrame$InitAppletEvent.dispatch(Compiled Code)
at java.awt.EventDispatchThread$EventPump.dispatchEvents(Compiled Code)
at java.awt.EventDispatchThread.run(Compiled Code)
at netscape.applet.DerivedAppletFrame$AppletEventDispatchThread.run(Compiled Code)
java.lang.IllegalMonitorStateException: current thread not owner
* at netscape.applet.DerivedAppletFrame$StopAppletEvent.dispatch(Compiled Code)
at java.awt.EventDispatchThread$EventPump.dispatchEvents(Compiled Code)
at java.awt.EventDispatchThread.run(Compiled Code)
at netscape.applet.DerivedAppletFrame$AppletEventDispatchThread.run(Compiled Code)
vivek bedekar
Greenhorn

Joined: Jun 19, 2001
Posts: 23
HI there,
just to check have u tried opening a console in IE ?
Dean Funk
Ranch Hand

Joined: Apr 20, 2001
Posts: 42
Seen this many times before: the standard suggestions to getting that left-side nav applet working are to dump browser cache then shutdown and restart your browser; shutdown and restart your machine; re-re-install WLS. I've had to do all three of those, but one of those always worked for me.
Good Luck.
Majid Khan
Ranch Hand

Joined: Oct 02, 2000
Posts: 92
I have the same problem .
I think it is a bug
It is something to do with the mbean not being invoked.
regards
Mac

Ram Kumar Rengarajan
Greenhorn

Joined: Apr 28, 2005
Posts: 22
hi,

I have the same problem also. I tried in IE. But I got the same error.. pls help us.

Ram..
Shankar Roy
Greenhorn

Joined: May 05, 2005
Posts: 4
Looks to me a permission issue in IE. Try changing the IE setiing to lower privacy setting and see if you get the admin console left pane.
ganapathy gopinathan
Ranch Hand

Joined: Aug 10, 2004
Posts: 30
Hi,

Have you installed JRE in your system? For the Left pane console,This is must. You can check, whether the JRE is enabled for this browser by going to 'Tools' option of browser and under that 'sun java console' option.

If you dont see this. Then JRE is not enabled for that Browser. For that
- Go to control panel
- Open the 'java plug-in'
- Go to the 'browser' tab.
- Check, whether your browser has been selected or not.
- If not, enable the browser.

Thanks
Gopi
Michael Gregarin
Greenhorn

Joined: Jun 01, 2005
Posts: 3
Gopi caught this issue from the exact angle. So in addition to his remarks, I would suggest to download the latest Java plugin from Sun's website. This should resolve the matter.
Hank Last
Greenhorn

Joined: Feb 16, 2006
Posts: 1
I've tried what Gopi suggested and I still cant get the console up. I've reduced security settings as well.

There are some postings here re our problem, can some one read them and translate:
http://www.javavietnam.org/javavn/mvnforum/printpost;jsessionid=886ACF21B8625F5D36134207A4C7A931?post=11753
Reid M. Pinchback
Ranch Hand

Joined: Jan 25, 2002
Posts: 775
I've hit this problem and was able to fix it. I got lucky - an office mate had recently hit the same problem and had changed something else recently enough that he knew the likely culprit. I wouldn't have spotted it because I made the same change when I wasn't using WebLogic for a couple of months - all I knew was that when I went back to doing WebLogic stuff mysteriously I didn't have anything in that left-hand frame.

The issue is that you need to have your browser's default JRE be one that the Weblogic console applet supports. In my case (WLS81sp4) the console went away when I installed JDK 1.5; your specifics may vary. Mucking around with that Java plug-in control panel never helped. The solution was to completely uninstall that JDK and JRE. Then I had the console back. Then I reinstalled 1.5 being careful to *not* replace the default browser JRE.

If you try that and are still stuck, I'd suggest bringing up a DOS prompt and doing "java -version" to see what you get. It may be that you've got some extra cleanup to do for some reason to get your O/S back to a point where JDK/JRE 1.4 is your default.
[ February 16, 2006: Message edited by: Reid M. Pinchback ]

Reid - SCJP2 (April 2002)
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Cannot view the left frame of admin console