aspose file tools*
The moose likes BEA/Weblogic and the fly likes URGENT-Weblogic 5.1 servlet not loading on startup Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "URGENT-Weblogic 5.1 servlet not loading on startup" Watch "URGENT-Weblogic 5.1 servlet not loading on startup" New topic
Author

URGENT-Weblogic 5.1 servlet not loading on startup

Vikram Agrawal
Greenhorn

Joined: Sep 30, 2001
Posts: 1
Hi all,
I am using Weblogic 5.1 and I want to load a servlet on startup.
I have added the following lines to my weblogic.properties
------------------------------------------
weblogic.httpd.register.BrokerAdmin=rss.web.BrokerAdminServlet
weblogic.system.startupClass.StartMyServlet=\
weblogic.servlet.utils.ServletStartup
weblogic.system.startupArgs.StartMyServlet=\
servlet=BrokerAdmin
------------------------------------------

The problem is that the BrokerAdminServlet is not loaded on startup, i.e. it's init() method is not called.

This is what weblogic log says---
Tue Oct 02 05:09:00 GMT+05:00 2001:<I> <WebLogicServer> Invoking T3StartupDef St
artMyServlet weblogic.servlet.utils.ServletStartup with {servlet=BrokerAdmin}
Tue Oct 02 05:09:00 GMT+05:00 2001:<I> <WebLogicServer> T3StartupDef StartMyServ
let weblogic.servlet.utils.ServletStartup reports:servlet: BrokerAdmin not found
Tue Oct 02 05:09:00 GMT+05:00 2001:<I> <ListenThread> Listening on port: 7771
Tue Oct 02 05:09:00 GMT+05:00 2001:<I> <SSLListenThread> Listening on port: 7772
Tue Oct 02 05:09:00 GMT+05:00 2001:<A> <Posix Performance Pack> Could not initia
lize POSIX Performance Pack.
Tue Oct 02 05:09:00 GMT+05:00 2001:<E> <Performance Pack> Unable to load perform
ance pack, using Java I/O.
Tue Oct 02 05:09:01 GMT+05:00 2001:<I> <WebLogicServer> WebLogic Server started
ANY HELP WOULD BE DEEPLY APPRECIATED
Regards,
Vikram
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16137
    
  21

It looks like your code isn't in the startup CLASSPATH.


Customer surveys are for companies who didn't pay proper attention to begin with.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: URGENT-Weblogic 5.1 servlet not loading on startup