aspose file tools*
The moose likes BEA/Weblogic and the fly likes question about weblogic 6.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "question about weblogic 6.1" Watch "question about weblogic 6.1" New topic
Author

question about weblogic 6.1

zhebincong
Greenhorn

Joined: Jan 14, 2002
Posts: 11
i am new to weblogic,i downloaded an evaluation version of weblogic6.1 for windows,i install it keeping up with the installatoin wizard,after that,select start->program->weblogic6.1->start default server,the dos windows appear,i can see the process in the window,but after about 5 seconds,the window close,and the server can't be started,the same thing happen to starting the example server,why?
i heat that in weblogic5 you should config the "weblogic.properties" file manually,but there is not such a file under the weblogic6.1 home directory,who can help me?
thank you
Ghlm Rashid
Greenhorn

Joined: Jan 13, 2002
Posts: 4
In weblogic6.x, there is no weblogic.properties file. We have one file called config.xml, which stores all the configuration attributes.
For more info read weblogic documents and I hope there is something wrong with your installattion check out with the instalaltion document.
It will helpful.
Thanx
Rashid
zb cong
Ranch Hand

Joined: Jan 14, 2002
Posts: 416
thanks for your answer,i don't think i have something wrong during the installation,nearly all of the parameter are default that the wizard give me,but there is one thing,i installed the weblogic on windowsXP beta2 version,i wonder if the weblogic support it,what's your opinion.
thank you!
Ghulam Rashid
Ranch Hand

Joined: Jan 14, 2002
Posts: 278
I am not sure about whether it is supported for XP. While downloading Weblogic, chexk out the supported Plateform.
Thanx
Rashid
Joe McGuire
Ranch Hand

Joined: Mar 19, 2001
Posts: 293
Does the startup process in the command window ever get to the point of asking you for your WebLogic password, or does it close out beforehand? You didn't install WebLogic as a Windows service, did you?
zb cong
Ranch Hand

Joined: Jan 14, 2002
Posts: 416
i can't see what it say,because the dos windows close soon,i think if it prompt me to input password,the window should stop there,but it can't.i do select "start weblogic as windows service" checkbox during the installation.
i have tried to install the weblogic in windows2000 and windowsXP,both the same result!why?
thanks for your help!
Joe McGuire
Ranch Hand

Joined: Mar 19, 2001
Posts: 293
If you checked to start WebLogic as a Windows Service at installation time, that would mean that WebLogic starts when Windows starts, and you already have an instance running. That is why it's closing out every time you try to re-start it.
Having it start as a service is to facilitate servers in production hosting a WebLogic app. When a machine is rebooted, WLS starts as well.
It is not for a development environment. Unfortunately, you'll have to uninstall WLS, and reinstall it not to run as a service. Try that and see if it works for you.
zb cong
Ranch Hand

Joined: Jan 14, 2002
Posts: 416
hello joe
what you mean is that if i have checked the start as windows service the server will start automatically,that my weblogic has already been running now,but when i try to start the default console,it fails.then i open dos windows,go weblogic directory,type "startweblogic" command,the output as follow,hope it help:
++++++++++++++++++++++++++++++++++++++++++++++++++
F:\wlserver6.1>set PATH=.\bin;F:\j2sdkee1.3\cloudscape\jre\bin;E:\WINDOWS\system32;E:\WINDOWS;E:\WINDOWS\System32\Wbem;F:\jdk1.3.0_01\bin;.;F:\Program Files\Microsoft SQL Server 2000 JDBC\lib\;E:\Program Files\Microsoft SQL Server\80\Tools\BINN;F:\jakarta-ant-1.3\bin;F:\j2sdkee1.3\bin
F:\wlserver6.1>set CLASSPATH=.;.\lib\weblogic_sp.jar;.\lib\weblogic.jar
F:\wlserver6.1>echo off
***************************************************
* To start WebLogic Server, use the password *
* assigned to the system user. The system *
* username and password must also be used to *
* access the WebLogic Server console from a web *
* browser. *
***************************************************
F:\wlserver6.1>"f:\jdk131\bin\java" -hotspot -ms64m -mx64m -classpath ".;.\lib\weblogic_sp.jar;.\lib\weblogic.jar" -Dweblogic.Domain=mydomain -Dweblogic.Name=myserver "-Dbea.home=f:\" -Dweblogic.management.password= -Dweblogic.ProductionModeEnabled=true "-Djava.security.policy==f:\wlserver6.1/lib/weblogic.policy" weblogic.Server
Usage: java [-options] class [args...]
(to execute a class)
or java -jar [-options] jarfile [args...]
(to execute a jar file)
where options include:
-hotspot to select the "hotspot" VM
-server to select the "server" VM
-classic to select the "classic" VM
If present, the option to select the VM must be first.
The default VM is -hotspot.
-cp -classpath <directories and zip/jar files separated by ;>
set search path for application classes and resources
-D<name>=<value>
set a system property
-verbose[:class|gc|jni]
enable verbose output
-version print product version and exit
-showversion print product version and continue
-? -help print this help message
-X print help on non-standard options
F:\wlserver6.1>goto finish
F:\wlserver6.1>cd config\mydomain
F:\wlserver6.1\config\mydomain>ENDLOCAL
+++++++++++++++++++++++++++++++++++++++++++++++++
thank you again
lucy hu
Ranch Hand

Joined: Aug 21, 2000
Posts: 60
I had the same problem before, make sure your license file is in the right place.
Lucy
zb cong
Ranch Hand

Joined: Jan 14, 2002
Posts: 416
hello lucy
i don't know which file is the licence file,i only download a installation file,double click it ...............,the bea company coudn't send me the licence too,please tell me
thanks
zb cong
Ranch Hand

Joined: Jan 14, 2002
Posts: 416
hello lucy
thanks for your reply,
i found two file "license.bea" and "license_new.bea" under the driver e after my installation,i think they should be within the weblogic home directory(E:\wlserver6.1),if need i move them?and where?
thank you
Naveen Sydney
Ranch Hand

Joined: Jan 21, 2002
Posts: 30
1) Check the control panel/services Look for weblogic if started kill it and try starting it again(the way u want to start it)
2) Ping the ip with the port number and see if u have an instance running
3) Do not use Xp yet weblogic6.x works fine on windows2000 if ur running on a windows platform
regards
syd
zb cong
Ranch Hand

Joined: Jan 14, 2002
Posts: 416
hello
i have check service,there is not weblogic in it,then i open dos windows to start weblogic,output as follow:
=================================================
Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-2000 Microsoft Corp.
F:\Documents and Settings\Administrator>e:
E:\>cd E:\wlserver6.1\config\mydomain\
E:\wlserver6.1\config\mydomain>startWebLogic.cmd
E:\wlserver6.1>set PATH=.\bin
E:\wlserver6.1>set CLASSPATH=.;F:\jdk1.3.0_01\lib\tools.jar;E:\wlserver6.1\lib\weblogic.jar
E:\wlserver6.1>echo off
***************************************************
* To start WebLogic Server, use the password *
* assigned to the system user. The system *
* username and password must also be used to *
* access the WebLogic Server console from a web *
* browser. *
***************************************************
E:\wlserver6.1>"F:\jdk1.3.0_01\bin\java" -hotspot -ms64m -mx64m -classpath ".;F:\jdk1.3.0_01\lib\tools.jar;E:\wlserver6.1\lib\weblogic.jar"
-Dweblogic.Domain=mydomain -Dweblogic.Name=myserver "-Dbea.home=e:\" -Dweblogic.management.password= -Dweblogic.ProductionModeEnabled=true "
-Djava.security.policy==e:\wlserver6.1/lib/weblogic.policy" weblogic.Server
Usage: java [-options] class [args...]
(to execute a class)
or java -jar [-options] jarfile [args...]
(to execute a jar file)
where options include:
-cp -classpath <directories and zip/jar files separated by ;>
set search path for application classes and resources
-D<name>=<value>
set a system property
-verbose[:class|gc|jni]
enable verbose output
-version print product version and exit
-showversion print product version and continue
-? -help print this help message
-X print help on non-standard options
E:\wlserver6.1>goto finish
E:\wlserver6.1>cd config\mydomain
E:\wlserver6.1\config\mydomain>ENDLOCAL
E:\wlserver6.1\config\mydomain>
==================================================
it don't seem like that weblogic has been started,
after that i start the default console from browser "http://127.0.0.1:7001/console",it don't work,my "startWeblogi.cmd" as follow:

+++++++++++++++++++++++++++++++++++++++++++++++++

@echo off
@rem This script can be used to start WebLogic Server. This script ensures that
@rem the server is started using the config.xml file found in this directory and
@rem that the CLASSPATH is set correctly. This script contains the following variables:
@rem
@rem JAVA_HOME - Determines the version of Java used to start
@rem WebLogic Server. This variable must point to the
@rem root directory of a JDK installation and will be set
@rem for you by the WebLogic Server installer. Note that
@rem this script uses the hotspot VM to run WebLogic Server.
@rem If you choose to use a JDK other than the one
@rem included in the disribution, make sure that the JDK
@rem includes the hotspot VM. See the WebLogic platform support
@rem page (http://e-docs.bea.com/wls/platforms/index.html)
@rem for an up-to-date list of supported JVMs on Windows NT.
@rem
@rem When setting these variables below, please use short file names (8.3).
@rem To display short (MS-DOS) filenames, use "dir /x". File names with
@rem spaces will break this script.
@rem
@rem jDriver for Oracle users: This script assumes that native libraries
@rem required for jDriver for Oracle have been installed in the proper
@rem location and that your system PATH variable has been set appropriately.
@rem For additional information, refer to Installing and Setting up WebLogic
@rem Server (http://e-docs.bea.com/wls/docs61/install/index.html).
SETLOCAL
cd ..\..
@rem Set user-defined variables.
set JAVA_HOME=F:\jdk1.3.0_01
@rem Check that script is being run from the appropriate directory
if not exist lib\weblogic.jar goto wrongplace
goto checkJDK

:wrongplace
echo startWebLogic.cmd must be run from the config\mydomain directory. 1>&2
goto finish
:checkJDK
if exist "%JAVA_HOME%/bin/javac.exe" goto runWebLogic
echo.
echo Javac wasn't found in directory %JAVA_HOME%/bin.
echo Please edit the startWebLogic.cmd script so that the JAVA_HOME
echo variable points to the root directory of your JDK installation.
goto finish
:runWebLogic
echo on
set PATH=.\bin
set CLASSPATH=.;F:\jdk1.3.0_01\lib\tools.jar;E:\wlserver6.1\lib\weblogic.jar
echo off
echo.
echo ***************************************************
echo * To start WebLogic Server, use the password *
echo * assigned to the system user. The system *
echo * username and password must also be used to *
echo * access the WebLogic Server console from a web *
echo * browser. *
echo ***************************************************
@rem Set WLS_PW equal to your system password for no password prompt server startup.
set WLS_PW=
@rem Set Production Mode. When set to true, the server starts up in
@rem production mode. When set to false, the server starts up in development
@rem mode. If not set, it is defaulted to false.
set STARTMODE=true
echo on
"%JAVA_HOME%\bin\java" -hotspot -ms64m -mx64m -classpath "%CLASSPATH%" -Dweblogic.Domain=mydomain -Dweblogic.Name=myserver "-Dbea.home=e:\" -Dweblogic.management.password=%WLS_PW% -Dweblogic.ProductionModeEnabled=%STARTMODE% "-Djava.security.policy==e:\wlserver6.1/lib/weblogic.policy" weblogic.Server
goto finish

:finish
cd config\mydomain
ENDLOCAL
+++++++++++++++++++++++++++++++++++++++++++++++++

any wrong?thanks
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: question about weblogic 6.1
 
Similar Threads
classes12.zip with WebLogic6.1
Is MultiPool concept in weblogic6.1 is complete new or was there in previous versions
license expired
Automate start/stop Admin Server and managed server for 11g
weblogic 6.0 installation on windows ME