aspose file tools*
The moose likes BEA/Weblogic and the fly likes Can not resolve symbol for bean class file in weblogic 6.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Can not resolve symbol for bean class file in weblogic 6.0" Watch "Can not resolve symbol for bean class file in weblogic 6.0" New topic
Author

Can not resolve symbol for bean class file in weblogic 6.0

Ashutosh Roy
Greenhorn

Joined: Jan 17, 2002
Posts: 8
Hi!
I am getting the error can not resolve the symbol.Is it because of I did not put the FormBean class file in appropriate folder in weblogi6.0 ?
Ashutosh

D:\bea\wlserver6.0\config\mydomain\applications\DefaultWebApp_myserver\WEB-INF\_tmp_war_myserver_myserver_DefaultWebApp_myserver\jsp_servlet\_process.java:95: cannot resolve symbol
symbol : class FormBean
location: class jsp_servlet._process
FormBean formHandler = (FormBean) //[ /process.jsp; Line: 10]
^
D:\bea\wlserver6.0\config\mydomain\applications\DefaultWebApp_myserver\WEB-INF\_tmp_war_myserver_myserver_DefaultWebApp_myserver\jsp_servlet\_process.java:95: cannot resolve symbol
symbol : class FormBean
location: class jsp_servlet._process
FormBean formHandler = (FormBean) //[ /process.jsp; Line: 10]
^
D:\bea\wlserver6.0\config\mydomain\applications\DefaultWebApp_myserver\WEB-INF\_tmp_war_myserver_myserver_DefaultWebApp_myserver\jsp_servlet\_process.java:100: cannot resolve symbol
symbol : class FormBean
location: class jsp_servlet._process
formHandler = (FormBean) java.beans.Beans.instantiate(getClass().getClassLoader(), "FormBean"); //[ /process.jsp; Line: 10]
^
3 errors


Ashu
Marcos Maia
Ranch Hand

Joined: Jan 06, 2001
Posts: 977
Hi, the error says that the class coul�d not be loaded by the classloader, so or you forgot to deplay this class or you have deployed it wrong.
Madhav.M
Greenhorn

Joined: Jan 29, 2002
Posts: 3
Hi, i am also getting the same error while wxwcuting the JSP pages . The ejb component is deployeed properly , that entry is showing in the JNDI tree .
Eckhard Beisswenger
Greenhorn

Joined: Jan 30, 2002
Posts: 6
Well, I get the same errors, too! I deployed a JSP application on WebLogic 6.1, containing a BeanClass which is correctly deployed in /WEB-INF/classes. Neither this class nor any classes or .jar files from the WEB-INF/lib directory can be loaded by the server. I always get the error message givven above. I tried all possible variations of mapping the files and there packages in the web.xml file, but it won't work. The classes themselves are alright, as I tested them in the IDE environment using the same directory structure.
Please help me/us!
Eckhard Beisswenger
Greenhorn

Joined: Jan 30, 2002
Posts: 6
Sorry, it seems that my problems have been solved: There was a wrong charset-encoding in my class files which made the server throw exceptions while booting. For this reason, the application was only partially deployed, and the classes containing the bad encoding could not be loaded. After changing the encoding to "ISO-8859-1", everything works fine again.
What can I/we learn from it: If the server cannot resolve a class name, the reason may be found by thoroughly checking the logfiles and messages during starting the server or deploying an application.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Can not resolve symbol for bean class file in weblogic 6.0