aspose file tools*
The moose likes BEA/Weblogic and the fly likes Oracle DataSource Config problem in WL 7.0 Server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Oracle DataSource Config problem in WL 7.0 Server" Watch "Oracle DataSource Config problem in WL 7.0 Server" New topic
Author

Oracle DataSource Config problem in WL 7.0 Server

Pearlo Muthukumaran
Ranch Hand

Joined: Sep 17, 2002
Posts: 79
Hi,
after creating the connection pool and attaching it to the server , i created a datasource and associated the same with connection pool but while setting the target server for the datasource i get the following exception at admin console :
java.lang.NullPointerException
at weblogic.management.console.utils.MBeans.getMBeanClassNameFor(MBeans.java:1153)
at weblogic.management.console.actions.mbean.EditMBeanAction.getMBeanClass(EditMBeanAction.java:210)
at weblogic.management.console.actions.mbean.EditMBeanAction.getDialogTypeKey(EditMBeanAction.java:188)
at weblogic.management.console.actions.internal.InternalActionContext.setAction(InternalActionContext.java:158)
at weblogic.management.console.actions.internal.ActionServlet.doAction(ActionServlet.java:170)
at weblogic.management.console.actions.internal.ActionServlet.doPost(ActionServlet.java:85)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStubImpl.java:945)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:332)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:242)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:5360)
at weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManager.java:721)
at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3043)
at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2468)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:152)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:133
AT THE SERVER CONSOLE I GET THE FOLLOWING ERROR MESSAGE:
<Sep 21, 2002 7:26:57 PM IST> <Error> <JDBC> <001059> <Error during Data Source
creation: java.lang.RuntimeException: User "principals=[weblogic]" does not have
permission for pearloJDBCConPool.
where could i be going wrong ??
I use the same username and password for starting the server and at admin console login

Regards
K.Muthukumaran
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Oracle DataSource Config problem in WL 7.0 Server