aspose file tools*
The moose likes BEA/Weblogic and the fly likes WLS6.1 - Configuring realm for openLdap Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of JavaScript Promises Essentials this week in the JavaScript forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "WLS6.1 - Configuring realm for openLdap" Watch "WLS6.1 - Configuring realm for openLdap" New topic
Author

WLS6.1 - Configuring realm for openLdap

Reshma Shanbhag
Ranch Hand

Joined: Sep 17, 2002
Posts: 203
Hi All,
I am trying to configure a realm for openLdap directory service to authenticate the users from openldap directory service.
While configuring i have set the following settings.

Realm Class Name: weblogic.security.ldaprealmv1.LDAPRealm
ldap url: ldap://ldap.gcr.com(the same url is been also set in ldap.conf file too)
Auth protocol: simple
User Authentication: Local
User Password Attribute: userpassword
User DN u=people,dc=gcr,dc=com
User Name Attribute: cn
Group DN: ou=groups,dc=gcr,dc=com
Group Name Attribute: cn
Group Username Attribute: member
Group Is Context: deselected
I populated the users on openldap directory service using the following LDIF file.
dn: dc=gcr,dc=com
objectclass: dcObject
objectclass: organization
o: GCR
dc: gcr
dn: ou=people,dc=gcr,dc=com
ou: people
objectclass: organizationalUnit
objectClass: top
dn: ou=groups, dc=gcr,dc=com
ou: groups
objectclass: organizationalUnit
objectClass: top
dn: ou=internal,ou=people,dc=gcr,dc=com
ou: internal
objectclass: top
objectclass: organizationalUnit
dn: cn=jhon,ou=internal,ou=people,dc=gcr,dc=com
objectclass: top
objectclass: person
cn: jhon
sn: j
userpassword: analytica
dn: cn=CQ_ADMIN,ou=groups,dc=gcr,dc=com
member: cn=jhon,ou=internal,ou=people,dc=gcr,dc=com
cn: CQ_ADMIN
description: This Contract Quickview Admin Group
objectClass: groupOfNames
objectClass: top
When i list users on ldap server, it shows me all the users. But when i try to authenticate the user jhon from the application deployed on weblogic server says, 'Authentication Faliure'.
I have no clue as whats happening here. If some one could help with this problem would be of great help to me.
Thanks in advance,
reshma


SCJP 1.4, SCWCD 1.4
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WLS6.1 - Configuring realm for openLdap