*
The moose likes BEA/Weblogic and the fly likes Strange issue with groups and roles in WLS 7.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Strange issue with groups and roles in WLS 7.0" Watch "Strange issue with groups and roles in WLS 7.0" New topic
Author

Strange issue with groups and roles in WLS 7.0

jason adam
Chicken Farmer ()
Ranch Hand

Joined: May 08, 2001
Posts: 1932
I've noticed something odd when dealing with roles, but not sure if it's just me, or a known issue.
I finally got Weblogic to authenticate users through Active Directory (woo hoo!). I have a set of roles defined, but that's where the problem comes in.
I can't seem to add a group name to a role unless that group is defined in Weblogic. Not only that, but if that group does not have a user assigned to it, I can't add the group to the role.
I'd like to be able to create roles that are assigned groups from AD, not ones defined in Weblogic. Is there a way to do this? I'd hate to have to create bogus users and groups just to allow proper authentication and role assignment to occur.
For instance, my account is in a group called analyst in AD. I have a role called Analyst, which states that members of the analyst group are assigned that role. This works when logging in with my AD account, but I have to create an analyst group in Weblogic, also, AND put a dummy user into the group. Kinda silly.
If anyone has experienced this, or might know what I am doing wrong, I'd appreciate the help.
Thanks!
 
Consider Paul's rocket mass heater.
 
subject: Strange issue with groups and roles in WLS 7.0
 
Similar Threads
How to configure Tomcat for authentication against Active Directory of Windows Server 2003
design a flexible application security
Accessing Role-Groups Mapped at Deploy time
User, Group, Roles for J2ee applications
Role management