File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes BEA/Weblogic and the fly likes Cluster Problem with WebLogic 6.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Cluster Problem with WebLogic 6.0" Watch "Cluster Problem with WebLogic 6.0" New topic
Author

Cluster Problem with WebLogic 6.0

BSA
Greenhorn

Joined: Sep 24, 2003
Posts: 1
Hi,
I am facing some problem related to weblogic6.0 (SP2)cluster setup.
I do have following setup,
1. Weblogic 6.0 cluster(Admin Server + Managed Server ) on machine A .
2. Weblogic 6.0 proxy server on other machine B.
Machine A and B are connected using internet.
Now the problem is when i try to access my application through machine B,
i get Internal Server error with following exception.
<exception>

####<Sep 23, 2003 9:14:16 AM CDT> <Error> <T3Services> <itimsrv2> <managed1> <ExecuteThread: '7' for queue: 'default'> <> <> <000000> <ERROR [ExecuteThread: '7' for queue: 'default'] com.access360.enrole.webclient.util.UserAuthHelper - Cannot parse POST parameters of request: '/UserAuthHelper'>
java.net.ProtocolException: EOF after reading only: '24966' of: '43608' promised bytes, out of which at least: '0' were already buffered
at weblogic.servlet.internal.PostInputStream.complain(PostInputStream.java:74)
at weblogic.servlet.internal.PostInputStream.read(PostInputStream.java:126)
at java.io.InputStream.read(InputStream.java:91)
at weblogic.servlet.internal.ServletInputStreamImpl.read(ServletInputStreamImpl.java:91)
at java.io.InputStreamReader.fill(InputStreamReader.java:173)
at java.io.InputStreamReader.read(InputStreamReader.java:249)
at weblogic.servlet.internal.ServletRequestImpl.mergePostParams(ServletRequestImpl.java:700)
at weblogic.servlet.internal.ServletRequestImpl.parseQueryParams(ServletRequestImpl.java:587)
at weblogic.servlet.internal.ServletRequestImpl.getParameter(ServletRequestImpl.java:739)
at weblogic.servlet.internal.ServletRequestImpl.getParameter(ServletRequestImpl.java:725)
at UserAuthHelper.getUserAuthInfo(UserAuthHelper.java:166)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:213)
at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:1265)
at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:1631)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:137)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
--------------- nested within: ------------------
weblogic.utils.NestedRuntimeException: Cannot parse POST parameters of request: '/UserAuthHelper' - with nested exception:
[java.net.ProtocolException: EOF after reading only: '24966' of: '43608' promised bytes, out of which at least: '0' were already buffered]
at weblogic.servlet.internal.ServletRequestImpl.mergePostParams(ServletRequestImpl.java:716)
at weblogic.servlet.internal.ServletRequestImpl.parseQueryParams(ServletRequestImpl.java:587)
at weblogic.servlet.internal.ServletRequestImpl.getParameter(ServletRequestImpl.java:739)
at weblogic.servlet.internal.ServletRequestImpl.getParameter(ServletRequestImpl.java:725)
</exception>
But if i use proxy on machine A, i don't get above exception!
Does this something do with netwrok speed between machine A and Machine B?
It seems the request object is not been send to Machine B from Machine A.
Thanks in advance for any inputs/suggestions/pointers.
- BSA
[ September 25, 2003: Message edited by: BSA ]
Raj Kethu
Greenhorn

Joined: Nov 10, 2005
Posts: 4
All,

Has anyone got solution for this. I am facing the same problem. Please throw light on this issue.

Thanks
Raj
Santosh Maskar
Ranch Hand

Joined: Jul 02, 2003
Posts: 226
http://forums.bea.com/bea/thread.jspa?threadID=200075876&messageID=202426571
Raj Kethu
Greenhorn

Joined: Nov 10, 2005
Posts: 4
Well No replies for my post. I think I found the solution for this


java -DHTTPClient.log.file=httpclient.log -DHTTPClient.forceHTTP_1.0=true -DHTTPClient.disableKeepAlives=true -DHTTPClient.dontTimeoutRespBody=true

Hope this helps,
Raj
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Cluster Problem with WebLogic 6.0