File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes BEA/Weblogic and the fly likes Problem in deploying application in weblogic8.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Problem in deploying application in weblogic8.1" Watch "Problem in deploying application in weblogic8.1" New topic
Author

Problem in deploying application in weblogic8.1

Aditya Prasad
Greenhorn

Joined: Sep 02, 2004
Posts: 13
Hi All
I have a web application and it's time i go for deployment.
we use Oracle as our back end.
i am using .ear file for deploying and this is generated in WSAD.
Now i want to deploy this in weblogic8.1
while configuring the connection pool, my Database type is oracle and i selected oracle driver(thin).i.e. my driver class name is Oracle.jdbc.xa.client.oracleXA.

The JNDI name that i use in my application is JDBC/IBS (IBS stands for internet banking service and this is my application) and the JNDI name that i specified for the Datasource is also JDBC/IBS.

Now after deploying the application and when i login to the page, i get
javax.naming.NameNotFoundException : while trying to lookup "ejbobject" didn't find subcontext resolved.......
the same error is showed for all the ejb objects that i use in my application.
Down these error's it says login user 'someusername' failed to be authenticated.

when i click the 'ejb-jar.xml' and 'weblogic-ejb-jar.xml' link it says "could not read descriptor file".


Can any one help me regarding this deployment in weblogic 8.1 ?
It's a bit urgent.I am very much new to this.

thanx in advance
Aditya
makiey bartsch
Greenhorn

Joined: Feb 27, 2002
Posts: 11
hi,

please try to test your ear file with a help of weblogic.appc tool:
java -classpath weblogic.jar weblogic.appc myApplication.ear

it will show you any errors/problems/missing descriptors etc.

greetings,
makiey
Aditya Prasad
Greenhorn

Joined: Sep 02, 2004
Posts: 13
Thanx a lot Mr. makiey
But can u pls help me how do i test my ear file with the help of weblogic.appc tool:
i tried the command java -classpath weblogic.jar weblogic.appc UBITEST31082004.ear (ibs is my application ear file) it says weblogic/appc not found.
Can u pls tell me what should i do ?
Here is my config.xml.(this file is in c\bea\user_projects\domains\Mydomainname)


<?xml version="1.0" encoding="UTF-8" ?>
- <Domain ConfigurationVersion="8.1.2.0" Name="ibs">
- <Server ListenAddress="" ListenPort="7001" Name="myserver" NativeIOEnabled="true" ReliableDeliveryPolicy="RMDefaultPolicy" ServerVersion="8.1.2.0" XMLEntityCache="XMLCacheMBean_myserver">
<SSL Enabled="false" HostnameVerificationIgnored="false" IdentityAndTrustLocations="KeyStores" Name="myserver" />
</Server>
<JMSFileStore Directory="rmfilestore" Name="FileStore" />
<WSReliableDeliveryPolicy DefaultRetryCount="10" DefaultTimeToLive="60000" Name="RMDefaultPolicy" Store="FileStore" />
<Security Name="ibs" PasswordPolicy="wl_default_password_policy" Realm="wl_default_realm" RealmSetup="true" />
<EmbeddedLDAP Credential="{3DES}UnY7i2T3d1o6GxvTKQsc6g97nKkMbnTBX7s96Kr0PnU=" Name="ibs" />
<SecurityConfiguration Credential="{3DES}d8Sb8z21tNYC9kjFJLh0qzWqk4pG74srx9EgUgvDOztWLBMC0nPe+xS9cZvE1PWStdnONijNQ3UTn5p5cPCoQjpLQZEVIspO" Name="ibs" RealmBootStrapVersion="1" />
<Realm FileRealm="wl_default_file_realm" Name="wl_default_realm" />
<FileRealm Name="wl_default_file_realm" />
<PasswordPolicy Name="wl_default_password_policy" />
- <JMSServer Name="WSStoreForwardInternalJMSServermyserver" Store="FileStore" Targets="myserver">
<JMSQueue CreationTime="1094167869968" JNDIName="jms.internal.queue.WSStoreForwardQueue" JNDINameReplicated="false" Name="WSInternaljms.internal.queue.WSStoreForwardQueuemyserver" />
<JMSQueue CreationTime="1094167870203" JNDIName="jms.internal.queue.WSDupsEliminationHistoryQueue" JNDINameReplicated="false" Name="WSInternaljms.internal.queue.WSDupsEliminationHistoryQueuemyserver" />
</JMSServer>
<XMLEntityCache Name="XMLCacheMBean_myserver" />
<JDBCConnectionPool DriverName="oracle.jdbc.driver.OracleDriver" Name="ibs" Password="{3DES}3dpNMvs48jE=" Properties="user=ebank" Targets="myserver" TestTableName="SQL SELECT 1 FROM DUAL" URL="jdbc racle:thin:@172.20.169.130:1521:ibank" />
<JDBCTxDataSource JNDIName="jdbc/ibs" Name="jdbc/ibs" PoolName="ibs" Targets="myserver" />
- <Application Name="UBITest31082004" Path="C:\Executables\EAR\UBITest31082004.ear" StagingMode="nostage" TwoPhase="true">
<EJBComponent Name="UBIEJB.jar" Targets="myserver" URI="UBIEJB.jar" />
<WebAppComponent Name="/" Targets="myserver" URI="UBIWeb.war" />
</Application>
</Domain>


I am breaking my head over this for more than a week.Any sort of help would be highly appreciated.

Regards
Aditya








Originally posted by makiey bartsch:
hi,

please try to test your ear file with a help of weblogic.appc tool:
java -classpath weblogic.jar weblogic.appc myApplication.ear

it will show you any errors/problems/missing descriptors etc.

greetings,
makiey
meka toka
Ranch Hand

Joined: Dec 11, 2002
Posts: 75
when i click the 'ejb-jar.xml' and 'weblogic-ejb-jar.xml' link it says "could not read descriptor file".

The reason for this is that you are deploying an ear that is generated by WSAD and to my knowledge WSAD doesnt generate descriptor files specific for Weblogic. So when you package your application you might have the generic J2EE descriptors which are application.xml, ejb-jar.xml and web.xml

i tried the command java -classpath weblogic.jar weblogic.appc UBITEST31082004.ear (ibs is my application ear file) it says weblogic/appc not found.

Where are you running the java command from ? You need to run this from the directory where the weblogic.jar is present or give the exact path where the jar file is present

You can find weblogic.jar in the location $BEA_HOME$/$WL_SERVER$/server/lib

I am assuming that in your case the location will be c:\bea\weblogic81\server\lib\weblogc.jar


Thanks<br />MekaToka<br />SCJP 1.4
Aditya Prasad
Greenhorn

Joined: Sep 02, 2004
Posts: 13
Thank u very much Meka Toka
i changed to the directory that u told.i.e. C:\bea\weblogic81\server\lib> and then i executed the java command.
But i still get an error.
pls look at what i did and correct me if i am wrong. I am very much new to J2EE and also to weblogic.

C:\bea\weblogic81\server\lib>java -classpath weblogic.jar weblogic.appc myApplic
ation.ear
Exception in thread "main" java.lang.NoClassDefFoundError: java/util/logging/Lev
el
at weblogic.j2ee.J2EELogger.logAppcSourceArgDoesNotExistLoggable(J2EELog
ger.java:2142)
at weblogic.appc.prepareInput(appc.java:233)
at weblogic.appc.runBody(appc.java:181)
at weblogic.utils.compiler.Tool.run(Tool.java:146)
at weblogic.utils.compiler.Tool.run(Tool.java:103)
at weblogic.appc.main(appc.java:1028)



Originally posted by meka toka:
when i click the 'ejb-jar.xml' and 'weblogic-ejb-jar.xml' link it says "could not read descriptor file".

The reason for this is that you are deploying an ear that is generated by WSAD and to my knowledge WSAD doesnt generate descriptor files specific for Weblogic. So when you package your application you might have the generic J2EE descriptors which are application.xml, ejb-jar.xml and web.xml

i tried the command java -classpath weblogic.jar weblogic.appc UBITEST31082004.ear (UBITEST31082004.ear is my application ear file) it says weblogic/appc not found.

Where are you running the java command from ? You need to run this from the directory where the weblogic.jar is present or give the exact path where the jar file is present

You can find weblogic.jar in the location $BEA_HOME$/$WL_SERVER$/server/lib

I am assuming that in your case the location will be c:\bea\weblogic81\server\lib\weblogc.jar
Sachin Dangi
Greenhorn

Joined: Aug 31, 2003
Posts: 17
Go to your domain directory and execute setEnv.cmd from command line prompt.

And then execute your appc command as given below. "setEnv.cmd" will put all the common jars in classpath.

java weblogic.appc myApplic
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem in deploying application in weblogic8.1