aspose file tools*
The moose likes BEA/Weblogic and the fly likes STRUTS + WEBLOGIC 8.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "STRUTS + WEBLOGIC 8.1" Watch "STRUTS + WEBLOGIC 8.1" New topic
Author

STRUTS + WEBLOGIC 8.1

Rajan Janakra
Greenhorn

Joined: Jun 21, 2005
Posts: 9
Hi All,
I deployed struts 2.0 based application in weblogic 8.1 .Deployment is sucessfull and throws the index page but not able to recognize .do extension. The same war file I was able to run under tomcat and netbeans 4.0. Could someone throw some light on this.
Thanks in advance.
My Web.xml Action Servlet Configuration and Filter Configuration.
<<
<servlet>
<servlet-name>action</servlet-name>
<servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
<init-param>
<param-name>config</param-name>
<param-value>/WEB-INF/struts-config.xml</param-value>
</init-param>
<init-param>
<param-name>debug</param-name>
<param-value>2</param-value>
</init-param>
<init-param>
<param-name>detail</param-name>
<param-value>2</param-value>
</init-param>
<load-on-startup>2</load-on-startup>
</servlet>


<!-- Standard Action Servlet Mapping -->
<servlet-mapping>
<servlet-name>action</servlet-name>
<url-pattern>*.do</url-pattern>
</servlet-mapping>

<filter>
<filter-name>ResponseOverrideFilter</filter-name>
<filter-class>org.displaytag.filter.ResponseOverrideFilter</filter-class>
</filter>

<filter-mapping>
<filter-name>ResponseOverrideFilter</filter-name>
<url-pattern>*.do</url-pattern>
</filter-mapping>


>>
Sincerely,
Rajan.
Rajan Janakra
Greenhorn

Joined: Jun 21, 2005
Posts: 9
Hey Guys,
I wonder If someone has done struts 2.0 based application deployment in weblogic 8.1. Any good links would be helpfull.
Rajan
Satish SN
Ranch Hand

Joined: Apr 19, 2005
Posts: 70
hi Rajan,

<servlet-mapping>
<servlet-name>action</servlet-name>
<url-pattern>*.do</url-pattern>
</servlet-mapping>

i think the hitch is in url-pattern becoz weblogic tend to believe in web-root-context thtat is u need to modify the

<servlet-mapping>
<servlet-name>action</servlet-name>
<url-pattern>/*.do</url-pattern>
</servlet-mapping>


this should solve ur problem..........

Keep Trying .....


Satish SN<br />SCJP 1.4 & SCWCD 1.4
Tim West
Ranch Hand

Joined: Mar 15, 2004
Posts: 539
My WLAS8.1/Struts1.2.4 app has the servlet mapping configured thus, which works fine:



Have you got a (possibly trivial) weblogic.xml in the appropriate part of the war? Also, why do you have load-on-startup as '2'? This is a boolean, so it should be 1 or 0. I've found Weblogic to be very fussy with things like this.

If you can't get it working, post the exception you're getting and perhaps we can help more.

My app has no filters configured though - perhaps you could try getting it going without the filter, to see if that's the problem.


-Tim
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: STRUTS + WEBLOGIC 8.1