• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

weblogicstarting problem

 
trinadh reddy
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i got this problem when starting the weblogic server.iam unable to trace the exact problem.please tell where the problem is


Nov 10, 2005 1:22:17 PM GMT+05:30> <Critical> <EmbeddedLDAP> <000000> <javax.xm
l.parsers.ParserConfigurationException: Namespace not supported by SAXParser
at com.sun.xml.parser.SAXParserImpl.<init>(SAXParserImpl.java:60)
at com.sun.xml.parser.SAXParserFactoryImpl.newSAXParser(SAXParserFactory
Impl.java:57)
at com.octetstring.vde.schema.InitSchema.init(InitSchema.java:53)
at weblogic.ldap.EmbeddedLDAP.initialize(EmbeddedLDAP.java:225)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:713)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:593)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:281)
at weblogic.Server.main(Server.java:32)
>
<Nov 10, 2005 1:22:17 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Failed to P
arse Schema: Namespace not supported by SAXParser>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'dc=mmmm': Object Class Not Found: top>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'ou=myrealm,dc=mmmm': Object Class Not Found: top>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'ou=ERole,ou=myrealm,dc=mmmm': Object Class Not Found: top>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'ou=EResource,ou=myrealm,dc=mmmm': Object Class Not Found: top>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'ou=EPredicate,ou=myrealm,dc=mmmm': Object Class Not Found: top>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'ou=EProfile,ou=myrealm,dc=mmmm': Object Class Not Found: top>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'ou=EProfileDefinition,ou=myrealm,dc=mmmm': Object Class Not Found:
top>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'ou=EProfileInstance,ou=myrealm,dc=mmmm': Object Class Not Found: t
op>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'cn=::Admin,ou=ERole,ou=myrealm,dc=mmmm': Object Class Not Found: t
op>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'cn=: eployer,ou=ERole,ou=myrealm,dc=mmmm': Object Class Not Found
: top>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'cn=: perator,ou=ERole,ou=myrealm,dc=mmmm': Object Class Not Found
: top>
<Nov 10, 2005 1:22:20 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'cn=::Monitor,ou=ERole,ou=myrealm,dc=mmmm': Object Class Not Found:
top>
<Nov 10, 2005 1:22:21 PM GMT+05:30> <Error> <EmbeddedLDAP> <000000> <Schema Viol
ation adding 'cn=::Anonymous,ou=ERole,ou=myrealm,dc=mmmm': Object Class Not Foun
d: top>
Failed to initialize default security realm: myrealm
<Nov 10, 2005 1:22:21 PM GMT+05:30> <Critical> <WebLogicServer> <000364> <Server
failed during initialization. Exception:weblogic.security.service.SecurityServi
ceRuntimeException: Failed to initialize default security realm myrealm for unkn
own reasons
weblogic.security.service.SecurityServiceRuntimeException: Failed to initialize
default security realm myrealm for unknown reasons
at weblogic.security.service.SecurityServiceManagerDelegateImpl.initiali
zeRealms(SecurityServiceManagerDelegateImpl.java:761)
at weblogic.security.service.SecurityServiceManagerDelegateImpl.initiali
ze(SecurityServiceManagerDelegateImpl.java:530)
at weblogic.security.service.SecurityServiceManager.initialize(SecurityS
erviceManager.java:922)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:719)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:593)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:281)
at weblogic.Server.main(Server.java:32)
>
<Nov 10, 2005 1:22:21 PM GMT+05:30> <Emergency> <WebLogicServer> <000342> <Unabl
e to initialize the server: Fatal initialization exception
Throwable: weblogic.security.service.SecurityServiceRuntimeException: Failed to
initialize default security realm myrealm for unknown reasons
weblogic.security.service.SecurityServiceRuntimeException: Failed to initialize
default security realm myrealm for unknown reasons
at weblogic.security.service.SecurityServiceManagerDelegateImpl.initiali
zeRealms(SecurityServiceManagerDelegateImpl.java:761)
at weblogic.security.service.SecurityServiceManagerDelegateImpl.initiali
ze(SecurityServiceManagerDelegateImpl.java:530)
at weblogic.security.service.SecurityServiceManager.initialize(SecurityS
erviceManager.java:922)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:719)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:593)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:281)
at weblogic.Server.main(Server.java:32)
>
***************************************************************************
The WebLogic Server did not start up properly.
Exception raised:
weblogic.security.service.SecurityServiceRuntimeException: Failed to initialize
default security realm myrealm for unknown reasons
at weblogic.security.service.SecurityServiceManagerDelegateImpl.initiali
zeRealms(SecurityServiceManagerDelegateImpl.java:761)

at weblogic.security.service.SecurityServiceManagerDelegateImpl.initiali
ze(SecurityServiceManagerDelegateImpl.java:530)
at weblogic.security.service.SecurityServiceManager.initialize(SecurityS
erviceManager.java:922)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:719)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:593)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:281)
at weblogic.Server.main(Server.java:32)
Reason: Fatal initialization exception
Throwable: weblogic.security.service.SecurityServiceRuntimeException: Failed to
initialize default security realm myrealm for unknown reasons
weblogic.security.service.SecurityServiceRuntimeException: Failed to initialize
default security realm myrealm for unknown reasons
at weblogic.security.service.SecurityServiceManagerDelegateImpl.initiali
zeRealms(SecurityServiceManagerDelegateImpl.java:761)
at weblogic.security.service.SecurityServiceManagerDelegateImpl.initiali
ze(SecurityServiceManagerDelegateImpl.java:530)
at weblogic.security.service.SecurityServiceManager.initialize(SecurityS
erviceManager.java:922)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:719)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:593)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:281)
at weblogic.Server.main(Server.java:32)
 
ankush purwar
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think you have modified the Realm setting for your weblogic domain in the wrong way.
Check it at your end.

Try to start example server in weblogic which comes in the installation of weblogic.If it works fine. It means you have installed the server properly.
 
pvsr rao
Ranch Hand
Posts: 102
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
no iam giving the command like this in the prompt
d:\bea\weblogic700\server\bin
java -Dweblogic.Domain=subdomain weblogic.Server
when i gave this command from that prompt weblogicserver should start with that domain
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic