jQuery in Action, 3rd edition
The moose likes BEA/Weblogic and the fly likes Siteminder Timeout Overriding Weblogic Timeout Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Siteminder Timeout Overriding Weblogic Timeout" Watch "Siteminder Timeout Overriding Weblogic Timeout" New topic

Siteminder Timeout Overriding Weblogic Timeout

orjun thengdi

Joined: May 13, 2006
Posts: 1

I wanted some inputs on the following senario... I have an application running on Struts - Weblogic - Oracle Framework. We have been using Siteminder and LDAP authentication with Weblogic. The problem is as follows...

Once a user logs in and is authenticated by Siteminder, there is a complex calculation that takes place in one of the Applications' modules ( which takes more than 1Hr.) Now so that the Weblogic session does not get timed (set to 30 min timeout) out we have written a refresh logic on the JSP that pings the Database every 90 seconds...

we are using the following URL which POSTs and redirects to the same JSP.


Even though this work well when we do not use Siteminder Authentication, with Siteminder, the Application gets timed out (redirects to login page) even though the calculation is continuning in the Background. I understand that there a 2 different timeout parameters for Siteminder and Weblogic. What I want to understand is how can siteminder timeout the session even though I am sending a request to the server every 90 seconds.
Also if someone can guide me for the solution of such a problem...

Thanks in advance
kri shan
Ranch Hand

Joined: Apr 08, 2004
Posts: 1432
Are you using Siteminder for SSO(Single-Sign-On) ? If yes, what LDAP does?
Pascal Roche

Joined: Jul 18, 2006
Posts: 1
Siteminder manages 2 differents session timeouts :
- idle timeout (happens after a given time of inactivity)
- maximum timeout (happens after a given time since the last authentication).
If you get a reauthentication page when you ping the server frequently, it's probably because your calculation exceeds the maximum timeout, so you should set the value of this parameter (in the session tab of the realm dialog box) greater than the maximum length of you calculation.
I agree. Here's the link: http://aspose.com/file-tools
subject: Siteminder Timeout Overriding Weblogic Timeout
It's not a secret anymore!