GeeCON Prague 2014*
The moose likes BEA/Weblogic and the fly likes Problem with weblogic/appc Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Problem with weblogic/appc" Watch "Problem with weblogic/appc" New topic
Author

Problem with weblogic/appc

Anselm Paulinus
Ranch Hand

Joined: Sep 05, 2003
Posts: 389
I am converting an application from Weblogic 7.1 to weblogic 9.1. Get the error java.lang.NoClassDefFoundError weblogic/appc I read the postings here on Javaranch but nothing seems to be working. In my classpath I have something like this .;c:\bea\weblogic91\server\lib\weblogic.jar

Will be happy if anyone can give me some suggestions on how to go about this.

I tried to build both from command line and ant, but end up with this same error.

Thanks,
Anselm.
[ July 10, 2006: Message edited by: Anselm Paulinus ]
Anselm Paulinus
Ranch Hand

Joined: Sep 05, 2003
Posts: 389
copied weblogic.jar into my make directory and is picked up by Ant I suppose but then another error crept up
<weblogic.appc failed to compile your application. Recompile with the -verbose option for
more details. Please see the error message(s) below.>
[exec] Result: 1
[exec] com/bea/xml/XmlException
Joe Ess
Bartender

Joined: Oct 29, 2001
Posts: 8914
    
    8

So did you recompile using "-verbose" so you could see the error? I know Weblogic versions get more strict with XML parsing with each new version, so you may have had something that slipped past in an older version.


"blabbing like a narcissistic fool with a superiority complex" ~ N.A.
[How To Ask Questions On JavaRanch]
 
GeeCON Prague 2014
 
subject: Problem with weblogic/appc