aspose file tools*
The moose likes BEA/Weblogic and the fly likes Weblogic platform8.1 SP4 installation error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Weblogic platform8.1 SP4 installation error" Watch "Weblogic platform8.1 SP4 installation error" New topic
Author

Weblogic platform8.1 SP4 installation error

Abraham Liu
Greenhorn

Joined: Aug 16, 2004
Posts: 3
Hi,
When I installed Weblogic platform8.1 SP4 under Solaris 9 Unix, I got error.

I typed the following command and executed:
java -jar apache-ant-1.6.5-bin.tar -mode=console
the following error messages shown on console,

$ java -jar net_pj_platform814_generic.jar -mode=console
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/bea/plateng/common/comdev/IControllable (Unsupported major.minor version 48.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:493)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:111)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:248)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:286)
at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:493)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:111)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:248)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:286)
at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)

Can anyone give me a rason? Is it possible that jdk131 is too old and short of some methods?

Thanks.

Abe Liu
Joe Ess
Bartender

Joined: Oct 29, 2001
Posts: 8927
    
    9

Basically you have a class compiled for a newer version of java and you are trying to run it with an older version. If you are using JDK 1.3, weblogic doesn't support that configuration.


"blabbing like a narcissistic fool with a superiority complex" ~ N.A.
[How To Ask Questions On JavaRanch]
 
Don't get me started about those stupid light bulbs.
 
subject: Weblogic platform8.1 SP4 installation error