permaculture playing cards*
The moose likes BEA/Weblogic and the fly likes Error 500--Internal Server Error-Null Pointer Exception Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Error 500--Internal Server Error-Null Pointer Exception" Watch "Error 500--Internal Server Error-Null Pointer Exception" New topic
Author

Error 500--Internal Server Error-Null Pointer Exception

Gaurav Bahl
Greenhorn

Joined: Jul 31, 2006
Posts: 1
When i am trying to logon to my application i got following error:-

at jsp_servlet._tiles.__layout._jspService(__layout.java:228)
at weblogic.servlet.jsp.JspBase.service(JspBase.java:33)
at
weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStu
bImpl.java:996)
at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:419
)
at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:28)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
at
weblogic.servlet.internal.RequestDispatcherImpl.forward(RequestDispatcherImpl.ja
va:316)
at
org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1033)
at
org.apache.struts.tiles.TilesRequestProcessor.doForward(TilesRequestProcessor.ja
va:269)
at
org.apache.struts.tiles.TilesRequestProcessor.processTilesDefinition(TilesReques
tProcessor.java:249)
at
org.apache.struts.tiles.TilesRequestProcessor.processForwardConfig(TilesRequestP
rocessor.java:303)
at
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1422)
at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:505)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at
weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStu
bImpl.java:996)
at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:419
)
at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:28)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
at
weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAp
pServletContext.java:6458)
at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.ja
va:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:118)
at
weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContex
t.java:3661)
at
weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:263
0)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)

--------------------------------------
But when i redeploy my application, and then try to login to my application it works fine.
This problem comes evertime when i restart my server. I am not supposed to redeploy my application manually evertime after i restart my server.
Can anybody suggest me why this problem is comming.
Parameswaran Thangavel
Ranch Hand

Joined: Mar 01, 2005
Posts: 485
Hi Gaurav
Me too getting the same error, but unfortunately re-deploying the application too is not working for me. i donno where i am making the mistake.
i pastetd the stacktrace that i got


<Aug 1, 2006 9:09:09 PM GMT+05:30> <Error> <HTTP> <BEA-101020> <[ServletContext(id=1592123,name=reprocess_IATPA,con
text-path=/reprocess_IATPA)] Servlet failed with Exception
java.lang.NullPointerException
at jsp_servlet._web_45_inf._jsp.__error._jspService(__error.java:239)
at weblogic.servlet.jsp.JspBase.service(JspBase.java:33)
at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStubImpl.java:1006)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:419)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:463)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:315)
at weblogic.servlet.internal.RequestDispatcherImpl.forward(RequestDispatcherImpl.java:322)
at org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1069)
at org.apache.struts.action.RequestProcessor.processForwardConfig(RequestProcessor.java:455)
at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:279)
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)
at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:525)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStubImpl.java:1006)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:419)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:315)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:671
8)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3764)
at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2644)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)



Any idea???
Rahul Mahindrakar
Ranch Hand

Joined: Jul 28, 2000
Posts: 1836
Hi

Are you able to locate the .java file for the jsp and check which line is causing the problem

Are you debugging custom code or some packaged application

Br
Rahul
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error 500--Internal Server Error-Null Pointer Exception
 
Similar Threads
EJB NameNotFoundException in WLS 8.1 SP 3
Problem with precompiled JSPs
EJB NameNotFoundException in WLS 8.1 SP 3
Software caused connection abort: socket write error
Problem with precompiled JSPs