Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

java.net.ConnectException:No available router to destination

 
karthik mahalingam
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
Im trying to setup an application in weblogic 7.1 and iam getting the following error

-------------------------
lid servlet reference.>
javax.naming.CommunicationException. Root exception is java.net.ConnectException: t3://localhost:7010: Destination
unreachable; nested exception is:
java.net.ConnectException: Connection refused: connect; No available router to destination
at weblogic.rjvm.RJVMFinder.findOrCreate(RJVMFinder.java:199)
at weblogic.rjvm.ServerURL.findOrCreateRJVM(ServerURL.java:125)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:296)

at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:239)

at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:135)
at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:662)
at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:243)
at javax.naming.InitialContext.init(InitialContext.java:219)
at javax.naming.InitialContext.<init>(InitialContext.java:175)
at weblogic.deployment.EnvironmentBuilder.findObject(EnvironmentBuilder.java:768)
at weblogic.deployment.EnvironmentBuilder.findObjectOrCreateLinkRef(EnvironmentBuilder.java:759)
at weblogic.deployment.EnvironmentBuilder.addUserTransaction(EnvironmentBuilder.java:555)
at weblogic.deployment.EnvironmentBuilder.<init>(EnvironmentBuilder.java:94)
at weblogic.servlet.internal.CompEnv.<init>(CompEnv.java:80)
at weblogic.servlet.internal.WebAppServletContext.init(WebAppServletContext.java:569)
at weblogic.servlet.internal.WebAppServletContext.<init>(WebAppServletContext.java:493)
at weblogic.servlet.internal.HttpServer.loadWebApp(HttpServer.java:628)
at weblogic.servlet.internal.WebAppModule.prepare(WebAppModule.java:626)
at weblogic.j2ee.J2EEApplicationContainer.prepareWebModule(J2EEApplicationContainer.java:3011)
at weblogic.j2ee.J2EEApplicationContainer.prepareModules(J2EEApplicationContainer.java:1532)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1188)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1031)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:822)
at weblogic.management.deploy.slave.SlaveDeployer$Application.prepare(SlaveDeployer.java:3057)
at weblogic.management.deploy.slave.SlaveDeployer.prepareAllApplications(SlaveDeployer.java:895)
at weblogic.management.deploy.slave.SlaveDeployer.resume(SlaveDeployer.java:363)
at weblogic.management.deploy.DeploymentManagerServerLifeCycleImpl.resume(DeploymentManagerServerLifeCycleIm
pl.java:229)
at weblogic.t3.srvr.SubsystemManager.resume(SubsystemManager.java:131)
at weblogic.t3.srvr.T3Srvr.resume(T3Srvr.java:964)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:359)
at weblogic.Server.main(Server.java:32)
--------------- nested within: ------------------
weblogic.utils.AssertionError: ***** ASSERTION FAILED *****[ Unable to create InitialContext ] - with nested excepti
on:
[javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3://localhost:7010: Destination
unreachable; nested exception is:
java.net.ConnectException: Connection refused: connect; No available router to destination]]
at weblogic.deployment.EnvironmentBuilder.findObject(EnvironmentBuilder.java:770)
at weblogic.deployment.EnvironmentBuilder.findObjectOrCreateLinkRef(EnvironmentBuilder.java:759)
at weblogic.deployment.EnvironmentBuilder.addUserTransaction(EnvironmentBuilder.java:555)
at weblogic.deployment.EnvironmentBuilder.<init>(EnvironmentBuilder.java:94)
--------------------------
Please do help me in fixing this error..
thanks
Karthik M
 
gopinathang nathan
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, seems to be server is not running/unreachabe.
- check whether the server is up and running?
- In general assertion error indicates bug.
- whether this is the first time you are getting this error or while redeploying?
- how do you try deploying? did you try anyother mode of deployment?
 
karthik mahalingam
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks for your reply gopinathang,
1.iam getting this error when iam trying to deploy my web module through the console of Weblogic server..
2.You said assertion error is an indication of a bug...can you just tell me where exactly that can happen while trying to deploy my web module..in xmls or where??
3.Iam getting this error during the first time of deployment itself..
4.I just make use of the weblogic console for deployment...that is just pointing my web folder from local...
Please clarify my queries..

Thanks in advance..
Karthik M
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic