It's not a secret anymore!*
The moose likes BEA/Weblogic and the fly likes Deploying .war on Weblogic Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Deploying .war on Weblogic" Watch "Deploying .war on Weblogic" New topic
Author

Deploying .war on Weblogic

TechTech
Greenhorn

Joined: Oct 05, 2007
Posts: 6
Hi
I have .war file that uses JavaEE5 I have deployed this sucessfully on tomcat,jboss,glassfish
But i see problem when i do it on Weblogic10
When i try to deploy it through deploytool
i get error meassages

An error occurred during activation of changes, please see the log for details.
Failed to load webapp: 'example.war'
javax.faces.webapp.FacesServlet

Can any one help me in deploying this..

Thanks
-Khaja
Dag Ragnar Larsen
Greenhorn

Joined: Oct 06, 2007
Posts: 2
Hi,

I have the same problem..... Can anyone please help?

I have deployed the jsf and jstl libraries that came with WebLogic 10, but still experience the same problem: java.lang.ClassNotFoundException: javax.faces.webapp.FacesServlet
Dag Ragnar Larsen
Greenhorn

Joined: Oct 06, 2007
Posts: 2
Problem solved!

This is what I did:

In web.xml added the following section inside <web-app>
<listener>
<listener-class>com.sun.faces.config.ConfigureListener</listener-class>
</listener>

Then I copied the following .jars to my domain /lib directory:
javax.servlet_2.5.jar
jsf-api.jar
jsf-impl.jar
jstl.jar
standard.jar

Don't exactly remember which jar that solved the problem.

Now I have a new problem, that is WL is not able to find the taglib used...
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Deploying .war on Weblogic