Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Using weblogic security roles in authentication: weblogic 9

 
Gireesh Nemath
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am trying to create a simple application which uses declarative authorization configured in web.xml. I use the simple form based authentication. While trying to deploy my application, I get the error:
weblogic.management.DeploymentException: [HTTP:101168]The security-role-assignment references an invalid security-role: LTVORole.

But I have defined the role LTVORole in weblogic using the administrator console.
below are the details of what I have done:

Web.xml:
========


weblogic.xml:
=============


Please help me find where I am going wrong...

Thanking you all in advance,
Gireesh.
NB: I have created the role in weblogic in the menu

security realms > myrealm > roles and policies > Global Roles > roles > LTVORole Is it the right way to define a role?
 
Gireesh Nemath
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,
When I removed weblogic.xml it worked. Wondering Why the documentation mandates us to use weblogic.xml for role-mapping (Probably I might have used an out-dated weblogic.xml file)

Thanking you all,
Gireesh
 
Div Menon
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
i am facing the same issue.tried commenting out the security role part in weblogic.xml but it still gives the same error.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic