• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

regarding error message in web app deployment

 
sri charan
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all,

When i trying to deploy a web application in weblogic8.1 it showing the following message

<Jan 8, 2008 1:45:53 PM IST> <Warning> <HTTP> <BEA-101248> <[Application: 'C:\bea\user_projects\domains\euro\applications', Module: 'invent']: Deployment descriptor "web.xml" is malformed. Check against the DTD: org.xml.sax.SAXParseException: cvc-elt.1: Cannot find the declaration of element 'web-app'. (line 6, column 52).>

i am using the same configuration as specified by the bea for weblogic8.1 . Can any through your view please.....
 
Phani Kumar
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Can you check the web.xml again?

Rgards,
kumar
 
sri charan
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for your response kumar,..... Here is the web.xml file which was generated by myeclipse ide......

<?xml version="1.0" encoding="UTF-8"?>
<web-app version="2.4"
xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">
<servlet>
<description>This is the description of my J2EE component</description>
<display-name>AdminSrv</display-name>
<servlet-name>Activsrv</servlet-name>
<servlet-class>com.inx.invpkg.Activsrv</servlet-class>
</servlet>

<servlet-mapping>
<servlet-name>Activsrv</servlet-name>
<url-pattern>/servlet/Activsrv</url-pattern>
</servlet-mapping>
</web-app>

I didn't change any thing in this.... except removing index.jsp file....
 
Ram Prasad
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi

if you are trying to use this web.xml without internet connection available it may fail sometimes. You can safely remove the DTD & xsd url specified.

that should solve the problem
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic