aspose file tools*
The moose likes BEA/Weblogic and the fly likes java.net.SocketException: Software caused connection abort: socket write error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "java.net.SocketException: Software caused connection abort: socket write error" Watch "java.net.SocketException: Software caused connection abort: socket write error" New topic
Author

java.net.SocketException: Software caused connection abort: socket write error

Hemanth H Bhat
Greenhorn

Joined: Apr 14, 2008
Posts: 15
hi everyone

I am using weblogic 8.1 and trying to post an XML of 40 MB size on the JMS queue
while posting this message i am getting the following exception and thus unable to post the message on the JMS queue can you please guide me in resolving this problem

Many Thanks
Hemanth
-------------------------------------------------------------------------
weblogic.jms.common.JMSException: Error sending message
at weblogic.jms.client.JMSProducer.sendInternal(JMSProducer.java:403)
at weblogic.jms.client.JMSProducer.send(JMSProducer.java:186)
at com.clsPostingMsg.main(clsPostingMsg.java:64)
Caused by: weblogic.rmi.extensions.RemoteRuntimeException: Unexpected Exception - with nested exception:
[java.net.SocketException: Software caused connection abort: socket write error]
at weblogic.jms.dispatcher.DispatcherImpl_814_WLStub.dispatchSyncTranFuture(Unknown Source)
at weblogic.jms.dispatcher.DispatcherWrapperState.dispatchSyncTran(DispatcherWrapperState.java:408)
at weblogic.jms.client.JMSProducer.sendInternal(JMSProducer.java:383)
... 2 more
Marcos Maia
Ranch Hand

Joined: Jan 06, 2001
Posts: 977
Hi,

you have to define message and/or bytes thresholds and quotas, as well as a maximum allowable message size on your JMS servers, destinations, and templates.
I'd also consider compressing the message.
Take a look at:
http://edocs.bea.com/wls/docs81/messaging.html

you'll find more information on this from this link.

regards.
Hemanth H Bhat
Greenhorn

Joined: Apr 14, 2008
Posts: 15
Thanks Marcos For your Timely reply

I made some configuration changes on the weblogic server as below

Click on the Name of the server (On which you have deployed your application and queues etc...)in the left Pane

Goto --> Protocols-->General--> Advanced Options
Increase the following Parameters

Complete Message Timeout:
Idle Connection Timeout:
Maximum Message Size:

By making these changes i am able to post the XML on the queue without any problems

Thanks
Hemanth
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: java.net.SocketException: Software caused connection abort: socket write error
 
Similar Threads
FTP in Java commons.net
Error while marshalling arguments
java.net.SocketException: Broken pipe
JMS Exception
weblogic jms common LostServerException