wood burning stoves*
The moose likes BEA/Weblogic and the fly likes weblogic jms common LostServerException Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "weblogic jms common LostServerException" Watch "weblogic jms common LostServerException" New topic
Author

weblogic jms common LostServerException

Hemanth H Bhat
Greenhorn

Joined: Apr 14, 2008
Posts: 15
Hi All

I am trying to post a message of 21MB (String message) on the JMS queue and i am getting the either of the following exception's during this .I am using weblogic 8.1 sp5

Kindly Note: I am successfully able to do this on the same version of weblogic server installed on my desktop machine with windows 2000 professional OS But when i am trying to do this on the UNIX OS(SunOS 5.8 Generic_117350-25) the following error occurs

....I googled a lot for the solution but this only says me that it is an networking issue can any one of you exactly guide me as to what do i need to change in the settings of either the Unix sun OS or the weblogic server to do away with this exception

I would really appreciate your inputs on this

Exception 1

weblogic.jms.common.LostServerException: ; nested exception is:
java.io.EOFException
at weblogic.jms.dispatcher.DispatcherWrapperState.dispatchSyncNoTran(DispatcherWrapperState.java:492)
at weblogic.jms.client.JMSProducer.sendInternal(JMSProducer.java:391)
at weblogic.jms.client.JMSProducer.send(JMSProducer.java:186)
at clsPostingMsg.main(clsPostingMsg.java:66)


Exception 2


weblogic.jms.common.JMSException: Error sending message
at weblogic.jms.client.JMSProducer.sendInternal(JMSProducer.java:403)
at weblogic.jms.client.JMSProducer.send(JMSProducer.java:186)
at clsPostingMsg.main(clsPostingMsg.java:66)
Caused by: weblogic.rmi.extensions.RemoteRuntimeException: Unexpected Exception - with nested exception:
[java.net.SocketException: Broken pipe]
at weblogic.jms.dispatcher.DispatcherImpl_815_WLStub.dispatchSyncNoTranFuture(Unknown Source)
at weblogic.jms.dispatcher.DispatcherWrapperState.dispatchSyncNoTran(DispatcherWrapperState.java:472)
at weblogic.jms.client.JMSProducer.sendInternal(JMSProducer.java:391)
Hemanth H Bhat
Greenhorn

Joined: Apr 14, 2008
Posts: 15
Hi All

I have found a solution for this problem and the problem is resolved

I made some configuration changes on the weblogic server as below

Click on the Name of the server (On which you have deployed your application and queues etc...)in the left Pane

Goto --> Protocols-->General--> Advanced Options
Increase the following Parameters

Complete Message Timeout:
Idle Connection Timeout:
Maximum Message Size:

Thanks
Hemanth
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: weblogic jms common LostServerException