aspose file tools*
The moose likes BEA/Weblogic and the fly likes Is weblogic 8.1 compatible with JDK 1.5? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Is weblogic 8.1 compatible with JDK 1.5?" Watch "Is weblogic 8.1 compatible with JDK 1.5?" New topic
Author

Is weblogic 8.1 compatible with JDK 1.5?

SaurabhSri Sri
Ranch Hand

Joined: May 01, 2008
Posts: 43
Hi All,

We have a requirement to update our server with JDK 1.5. We also have weblogic 8.1 running on that server. Would this activity come up with any compatibility issue?

Thanks in advance.

Regards
Saurabh


Regards
SaurabhSri (SCJP 1.5)
Roger Chung-Wee
Ranch Hand

Joined: Sep 29, 2002
Posts: 1683
WebLogic Server 8.1 supports JDK 1.4. You will need to migrate to at least WebLogic Server 9.0 in order to run JDK 1.5.


SCJP 1.4, SCWCD 1.3, SCBCD 1.3
SaurabhSri Sri
Ranch Hand

Joined: May 01, 2008
Posts: 43
Hi Roger,

Thanks for your replay. Migrating from weblogic 8.1 to weblogic 9.0 might be a complex activity for us, as so many application are deployed on weblogic 8.1.

Do we crate a domain which can use anyway jdk 1.5?
Roger Chung-Wee
Ranch Hand

Joined: Sep 29, 2002
Posts: 1683
You can have multiple JDKs installed on a server. Why would the presence of JDK 1.5 affect your WebLogic Server 8.1?
Amit M Tank
Ranch Hand

Joined: Mar 28, 2004
Posts: 257
I bet your weblogic8.1 server can not run on java 1.5.


Amit Tank
Linked In
prabup padmanathans
Greenhorn

Joined: May 27, 2008
Posts: 4
This is a business process , first try to migrate the projects deployed in 8.2 to 9.2 , it doesnt have so much complexity because server JDK5.0 have can accepts 1.4 too,but 1.5 in weblogic 8.1 is may not be possible
Jesper de Jong
Java Cowboy
Saloon Keeper

Joined: Aug 16, 2005
Posts: 14104
    
  16

There's no need to guess or bet if it will work or not.

Look at the documentation from BEA, especially this: Supported Configurations for WebLogic Platform 8.1.

WLS 8.1 is only guaranteed by BEA to work on the operating systems and JVM versions listed in the tables on that page. It might work on a newer JVM or it might not - either way, it's not guaranteed by BEA so it is not recommended to try it in a production environment.


Java Beginners FAQ - JavaRanch SCJP FAQ - The Java Tutorial - Java SE 7 API documentation
Scala Notes - My blog about Scala
Amit M Tank
Ranch Hand

Joined: Mar 28, 2004
Posts: 257
Just so you all know. I have tried using JDK 1.5 for weblogic8.1 and it gives some Exception like AssertionException when I start weblogic.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Is weblogic 8.1 compatible with JDK 1.5?