File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes BEA/Weblogic and the fly likes FileNotFound Exception Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "FileNotFound Exception " Watch "FileNotFound Exception " New topic
Author

FileNotFound Exception

Suresh Gopi
Ranch Hand

Joined: Mar 08, 2007
Posts: 49
Hello Friends,

I'm getting the following exception when i try to access my web application.

It has been working fine without any problem today i just modified one of the jsp (added new javascript function) and rebuilt the war and deployed it. I didn't get any error during deployment.

Even i reverted my recent changes and rebuilt it even after that it is not working.

What could be the problem?


Your inputs will be highly appreciated.Thanks in Advance.

Env Info:
BEA weblogic 8.1 SP5 :: Struts 1.2.x :: JDk 1.4.2

Please let me know if any other information is required.

Note: I didn't change anything in my struts-config.xml


21 Jul 2008 17:57:50,777 ERROR ExecuteThread: '2' for queue: 'weblogic.kernel.System' org.apache.struts.action.ActionServlet org.apache.struts.action.ActionServlet.handleConfigException(ActionServlet.java:1034) Parsing error processing resource path
java.io.FileNotFoundException: Response: '400: Bad Request' for url: 'http://jakarta.apache.org/struts/dtds/struts-config_1_2.dtd'
at weblogic.net.http.HttpURLConnection.getInputStream(HttpURLConnection.java:425)
at weblogic.net.http.SOAPHttpURLConnection.getInputStream(SOAPHttpURLConnection.java:28)
at java.net.URL.openStream(URL.java:913)
at weblogic.apache.xerces.impl.XMLEntityManager.startEntity(XMLEntityManager.java:836)
at weblogic.apache.xerces.impl.XMLEntityManager.startDTDEntity(XMLEntityManager.java:796)
at weblogic.apache.xerces.impl.XMLDTDScannerImpl.setInputSource(XMLDTDScannerImpl.java:275)
at weblogic.apache.xerces.impl.XMLDocumentScannerImpl$DTDDispatcher.dispatch(XMLDocumentScannerImpl.java:841)
at weblogic.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:329)
at weblogic.apache.xerces.parsers.DTDConfiguration.parse(DTDConfiguration.java:525)
at weblogic.apache.xerces.parsers.DTDConfiguration.parse(DTDConfiguration.java:581)
at weblogic.apache.xerces.parsers.XMLParser.parse(XMLParser.java:152)
at weblogic.apache.xerces.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1175)
at weblogic.xml.jaxp.WebLogicXMLReader.parse(WebLogicXMLReader.java:135)
at weblogic.xml.jaxp.RegistryXMLReader.parse(RegistryXMLReader.java:152)
at org.apache.commons.digester.Digester.parse(Digester.java:1572)
at org.apache.struts.action.ActionServlet.parseModuleConfigFile(ActionServlet.java:1006)
at org.apache.struts.action.ActionServlet.initModuleConfig(ActionServlet.java:955)
at org.apache.struts.action.ActionServlet.init(ActionServlet.java:470)
at javax.servlet.GenericServlet.init(GenericServlet.java:258)
at com.jnjvision.acuminderEcp.servlets.InitServlet.init(InitServlet.java:17)
at weblogic.servlet.internal.ServletStubImpl$ServletInitAction.run(ServletStubImpl.java:1094)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:970)
at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:949)
at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:888)
at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:3430)
at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:3375)
at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:3356)
at weblogic.servlet.internal.WebAppServletContext.setStarted(WebAppServletContext.java:6208)
at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:864)
at weblogic.j2ee.J2EEApplicationContainer.start(J2EEApplicationContainer.java:2134)
at weblogic.j2ee.J2EEApplicationContainer.activate(J2EEApplicationContainer.java:2175)
at weblogic.management.deploy.slave.SlaveDeployer$ComponentActivateTask.activateContainer(SlaveDeployer.java:2520)
at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.doCommit(SlaveDeployer.java:2438)
at weblogic.management.deploy.slave.SlaveDeployer$Task.commit(SlaveDeployer.java:2155)
at weblogic.management.deploy.slave.SlaveDeployer$Task.checkAutoCommit(SlaveDeployer.java:2254)
at weblogic.management.deploy.slave.SlaveDeployer$Task.prepare(SlaveDeployer.java:2149)
at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2401)
at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:883)
at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:591)
at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:500)
at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:224)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:183)
21 Jul 2008 17:57:51,489 ERROR ExecuteThread: '2' for queue: 'weblogic.kernel.System'


Regards<br />Suresh
Ali Al Ali
Greenhorn

Joined: Dec 29, 2007
Posts: 18
Dear Suresh,

Sometimes you face this problem because your IDE doesn't deploy well and you don't get the final work to be deployed, then you think that everything is working fine, but actually the result is comming from the previous work.

In other cases you fase this problem for no reason, in this case close the IDE or even you may restart the PC and you will find the result that you needed.

This is according to my experience, so if you have anything else then it will be good from you to tell me.


SCJP 1.4, SCWCD 1.4
Suresh Gopi
Ranch Hand

Joined: Mar 08, 2007
Posts: 49
Thanks a lot for your time Hadid.

Actually its working fine in my local machine but in QA environment i'm facing this problem. I'm not using IDE's auto deploy feature it QA env. I (manually) use admin console to stop and redeploy my web application.

Do you mean that war is not properly built? I tried to build 2 to 3 times..
Same set of files (war content) were working fine earlier.

(note: same version of server is being used in Development (Local) & QA env)
Suresh Gopi
Ranch Hand

Joined: Mar 08, 2007
Posts: 49
Problem solved now. Thanks Hadid.

Now this time i manually deleted the war and classes folder and rebuilt the WAR again.. (Earlier i used 'ant clean' to do this task)
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61205
    
  66

"Suresh", please check your private messages for an important administrative matter.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: FileNotFound Exception