wood burning stoves 2.0*
The moose likes BEA/Weblogic and the fly likes weblogic.Admin command not running Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "weblogic.Admin command not running" Watch "weblogic.Admin command not running" New topic
Author

weblogic.Admin command not running

Anand Bhatt
Ranch Hand

Joined: May 30, 2007
Posts: 189
My env varaible are set like:


Now when I am trying to run this from my command prompt:
C:\Documents and Settings\navbhatt>weblogic.Admin
I am getting like:

'weblogic.Admin' is not recognized as an internal or external command,
operable program or batch file.

Any idea why 'weblogic.Admin' is not recognized here?
Martijn Verburg
author
Bartender

Joined: Jun 24, 2003
Posts: 3274
    
    5

Originally posted by Anand Bhatt:
My env varaible are set like:


Now when I am trying to run this from my command prompt:
C:\Documents and Settings\navbhatt>weblogic.Admin
I am getting like:

'weblogic.Admin' is not recognized as an internal or external command,
operable program or batch file.

Any idea why 'weblogic.Admin' is not recognized here?


*Hint 1* Are you executing it with java?
*Hint 2* You need to think about your CLASSPATH

Cheers,
Martijn


Cheers, Martijn - Blog,
Twitter, PCGen, Ikasan, My The Well-Grounded Java Developer book!,
My start-up.
Anand Bhatt
Ranch Hand

Joined: May 30, 2007
Posts: 189
1* Are you executing it with java? I am not get this point

2:You need to think about your CLASSPATH : Path is already set there
Misha Ver
Ranch Hand

Joined: Mar 03, 2008
Posts: 470
Anand, do you know that weblogic.Admin utility is deprecated as of WebLogic Server 9.0?
Anand Bhatt
Ranch Hand

Joined: May 30, 2007
Posts: 189
My classpath is showing as:
CLASSPATH=;C:\bea9.2\patch_weblogic921\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\bea9.2\JDK150~1\lib\tools.jar
;C:\bea9.2\WEBLOG~1\server\lib\weblogic_sp.jar;C:\bea9.2\WEBLOG~1\server\lib\weblogic.jar;C:\bea9.2\WEBLOG~1\server\lib\webservice
s.jar;;C:\bea9.2\WEBLOG~1\common\eval\pointbase\lib\pbclient51.jar;C:\bea9.2\WEBLOG~1\server\lib\xqrl.jar;;
Martijn Verburg
author
Bartender

Joined: Jun 24, 2003
Posts: 3274
    
    5

A few points:

1.) See Misha's post, sounds like you're trying to run a deprecated utility

2.) Your CLASSPATH looks very suspicious to me (with all of the ~ characters), this is often caused by using windows directory structures, e.g. Is C:\bea9.2\WEBLOG~1\ a real directory? I'd used the full directory name but quote it.

2.a) Alternatively make sure that you have the jar files in a directory structure without spaces or ~ characters
Carol Enderlin
drifter
Ranch Hand

Joined: Oct 10, 2000
Posts: 1364
Any idea why 'weblogic.Admin' is not recognized here?

Originally posted by Anand Bhatt:
1* Are you executing it with java? I am not get this point



The command to run weblogic.Admin is
Anand Bhatt
Ranch Hand

Joined: May 30, 2007
Posts: 189
Hi Misha ,
This might be reason, as I am using weblogic9.2
 
Consider Paul's rocket mass heater.
 
subject: weblogic.Admin command not running
 
Similar Threads
can't get Java to run
Down loading software
Not able to run java
Command Prompt error- Can't run through compiler
Setting the classpath