aspose file tools*
The moose likes Websphere and the fly likes WAS installation problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "WAS installation problem" Watch "WAS installation problem" New topic
Author

WAS installation problem

Dharmesh Chheda
Ranch Hand

Joined: May 08, 2001
Posts: 204
Hello
I installed DB2 7 Enterprise edition and then WAS 3.5 advanced edition on my machine which has NT workstation installed,128MB RAM,celeron 600MHz and 10 GB hdd. Everything worked fine i was also able to start the default server and test the servlets though there was too much memory swapping .
The problem came now!!!
I uninstalled WAS 3.5 advanced edition and installed WAS 3.5 standard edition and kept the DB2 same. I dropped the WAS database and then started the standard edition installation.The installation went on smooth but then while starting the adminserver i got the error 10. on checking the WAS database i noticed that only the tables for the 'SYSIBM' schema were created and the tables for 'EJSADMIN' were missing.
Theres more.........
now i uninstalled WAS and DB2 both .. then i installed db2 enterprise edition 6.1 and then WAS 3.5 standard edition but when i start WAS installation it is not picking up the DB2 database and it is giving me the error
" YOUR CURRENT VERSION OF DB2 DOES NOT MEET THE LEVEL REQUIRED BY THE PRODUCT."
???
then again i uninstaled db2 6.1 and installed db2 5 thinking that WAS 3.5 standard edition might surely work on DB2 5
and again i am getting the same error while installing WAS
" YOUR CURRENT VERSION OF DB2 DOES NOT MEET THE LEVEL REQUIRED BY THE PRODUCT.5.2.11"
I have deleted the folders after uninstallation of both products and also deleted the registry entries which matter.And above all also installed DB2 fixpacks everytime.
Please if possible answer my following queries....
1> Is installation of WAS and DB2 on a workstation machine a good choice.? though WAS advanced worked very well..
2> For WAS 3.5 standard edition is it necessary to have DB2 standard also ?.. wont it take enterprise edition???
3> what are the DB2 requirements for WAS 3.5 standard edition
NOTE: on the ibm site it just mentions db2 5 or 6...
4> How do i go about the whole problem???....

NOTE: if possible reply fast cause i have my certification deadline 20 days from today... i need some solution soon and i am stuck....the certification is of WAS 3.5 standard.
While answering keep in mind that WAS 3.5 advanced and DB2 7.1 worked fine when i installed it ..so whats the problem

regards,<br />Dharmesh Chheda
Rahul Mahindrakar
Ranch Hand

Joined: Jul 28, 2000
Posts: 1859

what are the DB2 requirements for WAS 3.5 standard edition
NOTE: on the ibm site it just mentions db2 5 or 6...

I think that you require db2 UDB 7.1 with fixpack. This is a must.

NOTE: if possible reply fast cause i have my certification deadline 20 days from today... i need some solution soon and i am stuck....the certification is of WAS 3.5 standard.

for certification for the standard edition you do not need ejb's so if you just install advanced edition it is enough. Try the "Quick install" option and get things going.
Check out the infocenter documentation which documents the prerequisites for installation.


I installed DB2 7 Enterprise edition and then WAS 3.5 advanced edition on my machine which has NT workstation installed,128MB RAM,celeron 600MHz and 10 GB hdd. Everything worked fine i was also able to start the default server and test the servlets though there was too much memory swapping .
The problem came now!!!
I uninstalled WAS 3.5 advanced edition and installed WAS 3.5 standard edition and kept the DB2 same.

Try installing the advanced version if the problem persists as the advanced edition contains everything that the standard edition has plus it has ejb's.
Dharmesh Chheda
Ranch Hand

Joined: May 08, 2001
Posts: 204
I want to install standard edition cause i have less RAM and i was to get more comfortable for standard edition cause the questions in the certification are asked that way. i dont want the EJB's to be preloaded which occupy more memory .. so i think standard edition will run more efficiently on my machine?
Peter Kristensson
Ranch Hand

Joined: Jul 02, 2001
Posts: 118
If I'm not mistaken, Standard edition doesn't support EJB's at all, so they certainly won't be preloaded...
Dharmesh Chheda
Ranch Hand

Joined: May 08, 2001
Posts: 204
yeah peter Standard Edition doesnt have EJB support...
Hey thanx Rahul .. and peter ..for replying to this post... i have now successfully installed DB2 7.1 and WAS standard edition..
bye
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WAS installation problem