This week's book giveaway is in the OCPJP forum.
We're giving away four copies of OCA/OCP Java SE 7 Programmer I & II Study Guide and have Kathy Sierra & Bert Bates on-line!
See this thread for details.
The moose likes Websphere and the fly likes Installing Websphere Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Installing Websphere" Watch "Installing Websphere" New topic
Author

Installing Websphere

rajesh bn
Greenhorn

Joined: Sep 10, 2001
Posts: 3
I am trying to install IBM Websphere Advanced Server 3.5 on RedHat Linux 7.1
Since running the install.sh script doesnt install DB2 6.1 and IBMWebAS properly, I am trying to install the packages in the following order. But I could not create the WAS Database using createdb2.sh as db2inst1 because i get the following error:
A system error (reason code= "") occurred. Subsequent SQL statements could not be processed. SQLSTATE=58005
SQL1013N The database alias name or database name "WAS" could not be found. SQLSTATE=42705
Kindly let me know, if I am doing it right!
Here is what I did:
Installed IBM JDK 1.2.2 successfully.
Installed DB2 6.1 (comes with the installation files) successfully.
Uninstalled DB2 6.1 and installed DB2 fixpack 5 (comes with the installation)
installed WAS by doing rpm -ivh IBMWebAS-3.5ADV-1.i386.rpm
logged on as db2as and did db2admin start
logged on as db2inst1 and did
export LD_ASSUME_KERNEL=2.2.5
db2jstrt 6790
/opt/IBMWebAS/bin/createdb2.sh
got the following error:
A system error (reason code= "") occurred. Subsequent SQL statements could not be processed. SQLSTATE=58005
SQL1013N The database alias name or database name "WAS" could not be found. SQLSTATE=42705
Because of this error, i could not start the administration server using startupServer.sh
I get the same error.
Please let me know the sequence in which to do things so that
I could successfully install Websphere.
If i run install.sh, without installing individual packages manually, this is what i get:
Installing pre-requisites: Java: Version 1.2.2
Preparing... ########################################### [100%]
1:IBMJava2-SDK error: can't unlink /optIBMWebAS-RPMDELETE: Is a directory
error: can't unlink /optIBMWebAS-RPMDELETE: Is a directory
error: can't rename /optIBMWebAS to /optIBMWebAS-RPMDELETE: Is a directory
error: unpacking of archive failed on file /optIBMWebAS: cpio: unlink failed - Is a directory

Install and use IBM HTTP Server? [default is yes]
1.) Yes
2.) No
1

Installing IBM HTTP Server Version 1.3.12.2
Preparing... ########################################### [100%]
1:IBM_HTTP_Server ########################################### [100%]
/opt/IBMHTTPServer/bin/apachectl start: httpd started

Select the database you wish to use.
1.) DB2 [default]
2.) Custom
1
DB2 Selected
Installing db2.
./db2iresp: error while loading shared libraries: libncurses.so.4: cannot load shared object file: No such file or directory

Installing IBM WebSphere Application Server for Linux
Preparing... ########################################### [100%]
***************************************************************
Cannot find where java is installed on this system. Please
make sure the JDK or JRE is installed and set JAVA_HOME before
installing this package.
***************************************************************
error: execution of %pre scriptlet from IBMWebAS-3.5ADV-1 failed, exit status 1
error: skipping IBMWebAS-3.5ADV-1 install, %pre scriptlet failed rc 2
su: user db2inst1 does not exist
Preparing... ########################################### [100%]
1:IBMWebAS-ADV-doc-en ########################################### [100%]
Preparing... ########################################### [100%]
1:IBM_MSG_EN ########################################### [100%]

IBM WebSphere Application Server for Linux installation is complete.
Please run startupServer.sh in /opt/IBMWebAS/bin to invoke the server.
Also, please restart your webserver if you selected IHS at this time to
ensure the plugin configuration is updated. If you installed with Apache,
please refer to the install documentation for configuration information.

Preparing... ########################################### [100%]
1 ERJPICL ########################################### [100%]

Any suggestions welcome.
I have been trying all permutations and combinations in order to get WAS up and running.
Please let me know the sequence (workarounds) in which to do things so that I could successfully install Websphere.
Thanks.
Rajesh
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Installing Websphere