It's not a secret anymore!*
The moose likes Websphere and the fly likes Turn off directory listings Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Turn off directory listings" Watch "Turn off directory listings" New topic
Author

Turn off directory listings

Morten Moeller
Ranch Hand

Joined: Nov 26, 2001
Posts: 30
Should be a fairly simple thing but I cannot find where todo it
Instead of showing the files in a directory (when I goto the url http://mycomp.mydomain.com:9081/myapp/) I want a page to be shown. I've tried to add index files with various extensions, but noone seems to work.
How do you turn off directory listing and rather redirect it to some indexfile? Any help is really appriciated
- Morten
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
This doesn't sound like a WebSphere question. Does this have anything to do with IBM WebSphere?
Kyle


Kyle Brown, Author of Persistence in the Enterprise and Enterprise Java Programming with IBM Websphere, 2nd Edition
See my homepage at http://www.kyle-brown.com/ for other WebSphere information.
Morten Moeller
Ranch Hand

Joined: Nov 26, 2001
Posts: 30
Well just having a simple "index.jsp"/"index.XXX" works in weblogic and not in websphere..
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
OK -- I just really needed to find out if this really was a WebSphere question -- you wouldn't believe some of the off-topic questions that people put in this forum.
:roll:
Anyway, which version of WebSphere are you using and what is your configuration?
Kyle
[ January 10, 2002: Message edited by: Kyle Brown ]
Morten Moeller
Ranch Hand

Joined: Nov 26, 2001
Posts: 30
I explained it poorly Im sorry, but I figured it out.
We got a servlet that handles a certain extension (*.lsw) and on weblogic we sat the welcome-file to welcome.lsw .. This didn't work in websphere it seems like it tries to find the actual file. Instead I ended up with a directory listing. Using a jsp extension and make a jsp forward to welcome.lsw instead worked though.
dhanu varma
Greenhorn

Joined: Oct 26, 2001
Posts: 9
Hi Morten,
Try this if u r using websphere 3.5
In the file Enable Service of web application we can set the parameter in the advance tab as
---default.page as the name of the parameter and index.jsp as the value of the parameter and it works fine.
 
wood burning stoves
 
subject: Turn off directory listings
 
Similar Threads
package not found
ERROR: SRVE023E & PLGN0021E
Saving files in WAR file
Best practices for storing configuration/property files
stopping the application from displaying index.jsp