File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Websphere and the fly likes Problem starting up WAS v3.5 standard edition Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Problem starting up WAS v3.5 standard edition " Watch "Problem starting up WAS v3.5 standard edition " New topic
Author

Problem starting up WAS v3.5 standard edition

Shireen Loke
Greenhorn

Joined: Jan 05, 2002
Posts: 12
Hi,
I have successfully installed WAS v3.5 Standard Edition on Linux RedHat version 7.2, but I have problem starting up the server. When I type /opt/IBMWebAS/bin/./startupServer.sh, I got the following error from the trace log.
_______________________________________________
[root@timecard bin]# tail -f ../logs/tracefile
at com.ibm.ejs.sm.server.AdminServer.initializeRuntime(AdminServer.java:
959)
at com.ibm.ejs.sm.server.AdminServer.main(AdminServer.java:353)
java.lang.Throwable
at java.lang.Throwable.<init>(Throwable.java:84)
at com.ibm.ejs.ras.CBuffLogger.fatalEvent(CBuffLogger.java:420)
at com.ibm.ejs.ras.Tr.fireTraceEvent(Tr.java:502)
at com.ibm.ejs.ras.Tr.fatal(Tr.java:859)
at com.ibm.ejs.sm.server.AdminServer.initializeRuntime(AdminServer.java:
961)
at com.ibm.ejs.sm.server.AdminServer.main(AdminServer.java:353)
__________________________________________________

FYI, my database used is PostgreSQL, not DB2. Do you think the problem is here with the admin.config file setting. I indeed tried modifying the admin.config file even though it is not an appropriate way to do so. I modified the dbUser, dbPassword, dbDriver, dbURL, and the classpath so that it knows where to find the jdbc driver file. BUT I failed to start the server again with the same message.
I know how to deal with this problem in WAS v4.0 Advanced Edition as I can start the admin console once finishing installed WAS4.0 (the console can be launched easily from the firststeps.sh which pop up automatically).
Can anyone tell me how I can do resolve the start up problem in V3.5 Standard Edition?
Tony Chen
Ranch Hand

Joined: Jan 29, 2001
Posts: 286
PostgreSQL is not supported!
Check out the software prerequisites:
http://www-4.ibm.com/software/webservers/appserv/doc/v35/idx_aas.htm


SCJP Java 2 - IBM Certified Enterprise Developer - WebSphere V4.0 & V5.0 - IBM Certified System Administrator - WebSphere Network Deployment V6.0 - Canadian Securities Course (CSC) Certification
Shireen Loke
Greenhorn

Joined: Jan 05, 2002
Posts: 12
Tony,
I wonder if the prerequisites stated on the web site is accurate as I got PostgreSQL worked fine with WAS40 Advanced Edition although it didn't mention postgreSQL was supported.
Besides, I found out something that might be critical to the problem I am facing now. According to the installation guide, I need to install pdksh before calling the command ./install.sh. What I did was that I missed the pdksh part. Is it a MUST that I need to install pdksh before installing WAS V3.5?
Let's assume that this is true. How do I uninstall WAS V3.5? There is a directory named UnInst under /opt/IBMWebAS, however, there is no such thing call uninstall.sh as mentioned on some of the .pdf I downloaded from IBM web sites.
As you know both WAS40 and WAS35, what is the difference between the two in terms of the installation steps (not the features of the two)? To me, with WAS40 Advanced Edition, the server can be started with just a click as the whole installation is GUI. With WAS35 Standard Edition, install.sh won't lead me to a GUI which I can do with just a click.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem starting up WAS v3.5 standard edition
 
Similar Threads
IBM Websphere 3.5
WebSphere Starting Problem
was admin server couldn't start
Cannot start WAS with Oracle
Any idea why i get this error in the log file