File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Websphere and the fly likes Problem with JNDI lookup in WAS 4.02 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Problem with JNDI lookup in WAS 4.02" Watch "Problem with JNDI lookup in WAS 4.02" New topic
Author

Problem with JNDI lookup in WAS 4.02

Binh Nguyen
Greenhorn

Joined: Feb 28, 2002
Posts: 16
I have encountered a strnage problem, please tell me what I have dome wrong:
in my Admin Console, I set up the following
Connectin pooling, jndi: jdbc/myDataSource
ejb, jndi: ejb/myEjb
and I tried the following:
when I install a WAR module alone, and WAR module did not use any EJB, and I did not specify the "Resource Reference", then to look up for the data-source, jdbc/myDataSource, it works
when I package my WAR module together with EJB module to an EAR file, what the folowing step:
if I specify that the WAR use the DataSource, by setting the "Reference Resource", then I can get the DataSource with the jndi look up string:
"jdbc/myDataSource" in my code, it worked fine
but if I also specified that my WAW module also use the EBJ, by setting the "EJB reference" in the WAR module, then I cannot obtain the Datasource anymore?
I dont know what shou;d do then?
thank you vey much
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem with JNDI lookup in WAS 4.02
 
Similar Threads
WSAD and Connection Pools
regarding JNDI
EJB and Resource references
CMP Bean
Cannot get Spring database connection work