wood burning stoves 2.0*
The moose likes Websphere and the fly likes very very  urgent...pl respond.. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "very very  urgent...pl respond.." Watch "very very  urgent...pl respond.." New topic
Author

very very urgent...pl respond..

myid
Greenhorn

Joined: Feb 19, 2002
Posts: 16
Hi...all..
here iam using websphere 4.0 AEs.just week back we moved to websphere.as of now we were in to weblogic.now we r trying to run application in to websphere 4.0 AES.here the problem is i got succeed in deploying application and my application was started in console.iam not able to run my jsp through browser.does any one can help me how to run my sample jsp in webpshere 4.0 AES?or else could u explian me the process of running test jsp in websphere 4.0 AEs?what is the url i have to usae to call?already i userd localhost:9080/test.jsp. but iam getting 404 error.ur help is very much needful...
thx
seshu
Binh Nguyen
Greenhorn

Joined: Feb 28, 2002
Posts: 16
to load a jsp from your app, you have to call it from a context-root that you mapped your applicaton to. For example, you mapped you application to: myApp, and you jsp at the root level, then you ccan load your jsp with the URL:
http://localhost:9080/myApp/myPage.jsp
or
http://localhost:9080/myApp/sub-dir/myPage.jsp
if your myPage.jsp is stored under "sub-dir" off the context root.
Hope this helps
Binh
myid
Greenhorn

Joined: Feb 19, 2002
Posts: 16
hi..Binah...
thank u very much.but could u tell me where can we give the context path?suppose if my .war is in websphere\appserver\classes,can i give the context root like that?if so where can i get the context path option?
waiting for ur response...
thx..
seshu..
vb reddy
Greenhorn

Joined: Oct 18, 2000
Posts: 14
You can specify the context root for a web module during deployement using AdminConsole or while pakcaging your web components into a WAR using Application Assembly tool(AAT)..
context root for a web module is not the path where you have your module archives(WAR or EAR), it is simple unique name which will be added to the URL while accesing web components belonging to the respective web module.
Ex: As somebody said already,If the context root of a web module is myApp, and to access a jsp file use this URL
http://localhost:9080/myApp/index.jsp
Note: In WAS4.0 all URL names are case sensitive.
Venu.
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
Wait a minute -- you DO NOT put your war in the /classes directory. You have to deploy it with the administrative console.
READ THE INFOCENTER!
That will tell you how to set up the context root as well.
Kyle


Kyle Brown, Author of Persistence in the Enterprise and Enterprise Java Programming with IBM Websphere, 2nd Edition
See my homepage at http://www.kyle-brown.com/ for other WebSphere information.
myid
Greenhorn

Joined: Feb 19, 2002
Posts: 16
hi..venu and kyle..
thx for advises,but here the process i did for my test.jsp is like this.
i have created .war using webmodule wizard for test.jsp and i have created .ear with this .war.
now i dont have any jars.only i have one war in my ear.now i had installed this in console and i started that.while cretaing application wizard i mean in creting .ear it self it was asked me about context root.there i have given some websamp.now i have started my application in console.it was started successfully,now iam calling my jsp as http://localhost:9080/websamp/test.jsp.but still iam not able to run my jsp .
could u pl explain me the process in detail?i was strucked for this almost for a week back.
once again thanking u for ur response..
pl write me some thing on this..
thx..
seshu
ersin eser
Ranch Hand

Joined: Feb 22, 2001
Posts: 1072
myid and Xenoux

Please read the Javaranch Naming Policy and change your publicly displayed name to comply with our unique rule. Thank you for your cooperation.
vb reddy
Greenhorn

Joined: Oct 18, 2000
Posts: 14
1.What is the error the browser is showing, is it 404 error again?.
2. Did you created a web component for test.jsp inside your WAR or you have just added the test.jsp to the WAR?
I bet nobody reaches this stage, but in worst case you need to check your transport settings for web container service(check if the port number is not 9080).
I leave this to big hand, who can give you better suggestions..
Venu.
myid
Greenhorn

Joined: Feb 19, 2002
Posts: 16
Hi..Venu..
the process i did is like this...pl try to spend bit time on this..today also i tried for this and got frustarted..
the procee i did is:
1)first i have written one test.jsp
2)i kept this in websphere\appserver\classes
3)i have created one test.jar with this jsp and i kept this in websphere\appserver\classes;
4)now i have opened AAT and it showed me one unamed.war under this i find websomponents option.after right click on this webcomponent and i added this Test.jsp to this unnamed.war.now i saved this war in websphere\appserver\bin directory.after saving this by right clciking this war it asked me for properties, there i have given the path as websphere\apperver\classes\Test.jar
5)now again in AAT i created one application with test.ear.for this ear i added this test.war.
6)while adding it self it was asked me context root
7) there just i have given name "web".
8)now i save that Test.eat and deployed that in workbench.(in AAT it self )
9)now i had test.war in mt Test.ear application.
10)now i have opened my console and by choosing the enterprise applications option it asked me to install.
11) there i have browsed for the deployed Test.ear and i installed that.
11) mean while i checked the jvm settings and hhtp service settings and all.
12)every thing is fine.
13) i stopped the server and restarted it.
14) now i am succeed in starting my Test.ear in the doown of petstore application which was already ther.
15)now i stopped the both websphere and http servers and restarted it.
16) now i opened my browser and typed http://localhost:9080/web/Test.jsp.
17)i got 404 not found error..
could u pl tell me the way to run this?
pl spend some time on this..
if i checked my installed apps folder every thing is fine..
thx in advance.ur help is very much needful..
seshu
ersin eser
Ranch Hand

Joined: Feb 22, 2001
Posts: 1072
myid
Please read the Javaranch Naming Policy and change your publicly displayed name to comply with our unique rule. Thank you for your cooperation.
myid
Greenhorn

Joined: Feb 19, 2002
Posts: 16
Hi..Venu..
the process i did is like this...pl try to spend bit time on this..today also i tried for this and got frustarted..
the procee i did is:
1)first i have written one test.jsp
2)i kept this in websphere\appserver\classes
3)i have created one test.jar with this jsp and i kept this in websphere\appserver\classes;
4)now i have opened AAT and it showed me one unamed.war under this i find websomponents option.after right click on this webcomponent and i added this Test.jsp to this unnamed.war.now i saved this war in websphere\appserver\bin directory.after saving this by right clciking this war it asked me for properties, there i have given the path as websphere\apperver\classes\Test.jar
5)now again in AAT i created one application with test.ear.for this ear i added this test.war.
6)while adding it self it was asked me context root
7) there just i have given name "web".
8)now i save that Test.eat and deployed that in workbench.(in AAT it self )
9)now i had test.war in mt Test.ear application.
10)now i have opened my console and by choosing the enterprise applications option it asked me to install.
11) there i have browsed for the deployed Test.ear and i installed that.
11) mean while i checked the jvm settings and hhtp service settings and all.
12)every thing is fine.
13) i stopped the server and restarted it.
14) now i am succeed in starting my Test.ear in the doown of petstore application which was already ther.
15)now i stopped the both websphere and http servers and restarted it.
16) now i opened my browser and typed http://localhost:9080/web/Test.jsp.
17)i got 404 not found error..
could u pl tell me the way to run this?
pl spend some time on this..
if i checked my installed apps folder every thing is fine..
thx in advance.ur help is very much needful..
--------------------------------------------------------------------------------
vb reddy
Greenhorn

Joined: Oct 18, 2000
Posts: 14
:roll: wait
myid
Greenhorn

Joined: Feb 19, 2002
Posts: 16
hi..venu..
coud u write on my last query..
waiting for that..
thx..
bill williams
Ranch Hand

Joined: Jan 15, 2002
Posts: 94
myid, read this paper and the word file in the downloaded zip file.
http://www-106.ibm.com/developerworks/ibm/library/i-ejbpaper/?n-dd-12201


Yet Another SCJP2
myid
Greenhorn

Joined: Feb 19, 2002
Posts: 16
hi..
thats ok...iam able to install my application in console and i got succeed in starting my application.
but iam getting 404 file not found when i tried to run my client.even iam not able to get my welcome page,which is an html page.
so can any body act on this?it's ver very urgent pl.......
venu try to write me on this..or else if any body can write how to run simple jsp in websphere4.0 that'll be greatful ...
thx..
myid(seshu)
Se Ravin
Greenhorn

Joined: Feb 18, 2002
Posts: 26
Hi Myrid,
Did u check whether the WebServer plugin has been regenrated,check the file plugin-config.xml and see whether webapp is mentioned there,if not
go to console and regenerate the webserver plugin.
The webserver plugin always refers the file for checking whether ur app has been registered and if not displays a 404 error.
If the automatic regeneration of plugin has not been set to true,this problems happens
Regs
Senthil


We are and We are Not
Se Ravin
Greenhorn

Joined: Feb 18, 2002
Posts: 26
And moreover u need not bundle ur jsp's in a jar if u enable file serving option of the webmodule to true.(I do this way Only)
Paresh Sharma
Ranch Hand

Joined: Nov 12, 2001
Posts: 34
myid,
have u set the virtual host. The request from your webserver plugin has to reach the Application server.
Make sure there is an entry like "localhost:9080" in the virtual host settings.
Paresh


mail me @ pareshs76@hotmail.com<br />Websphere 4.0 Certified Administrator<br />BEA Weblogic 5.1 Certified Developer<br />Sun Certified Java Programmer
myid
Greenhorn

Joined: Feb 19, 2002
Posts: 16
hi..
really igot frustrated with this.iam struggling with this for last couple of days.i have checked every thing .every thing is fine in both console and AAT.i dont know why iam not able to run my jsp.so would u mind pl send me total process how to run sample jsp in websphere4.0.i'll be very much greatful about u.
waiting for ur respnse..
thx..
myid(seshu)
Se Ravin
Greenhorn

Joined: Feb 18, 2002
Posts: 26
Hi Myrid,
1) Create a jar file with a dummy resource,and while creating check the file serving enabled option to true.
2) Install the war into an application from WebSphere console.
3)After successful installation check whether
<WebSphere installed root>/installedApps/<webapp.ear>/<webapp.war> exists and copy ur jsp file into the foresaid directory
4)Check whether <WebSphere installed root>/config/plugin-cfg.xml is having an entry for ur webapp (just do a search )
5)If itz not there ,regenerate the WebServer plugin.
6)Stop Server and start,now ur plugin-cfg.xml SHOULD contain an entry for ur webapp.
7)Invoke ur jsp,Bingo itshould work.
If u still have problems,send me a mail to
javaarch@rediffmail.com.
Dont worry U r not alone,I faced the same problem and finally i managed to trace the problem.
Regs
Senthil
myid
Greenhorn

Joined: Feb 19, 2002
Posts: 16
hi..
thx senthil.
lets assume the scenario like this i have mytest.jsp and i want to run it in websphere4.0.
so pl could u keep this in mind and let me know the steps from A to z both in console and AAT.
iam expecting detailed reply from u..sorry for troubling u.
thx..
seshu
Carl Trusiak
Sheriff

Joined: Jun 13, 2000
Posts: 3340
myid,
You were politely requested twice to change your Display name to comply with our Naming Policy
Since you choose to ignore the request you will now have to reregister with a proper display name.
seradmin
Greenhorn

Joined: Mar 14, 2002
Posts: 14
hi..all..
i got the solution,finally iam able to run my test application.
ok..tahkks to all...each and every body especiolly venu and senthil and all..
oce again thx..
seradmin(seshu)
Carl Trusiak
Sheriff

Joined: Jun 13, 2000
Posts: 3340
seradmin,
Continue to ignore our Naming Policy and I'll be forced to block your IP address. Change Your Display Name to comply with the policy
[ March 15, 2002: Message edited by: Carl Trusiak ]
Radhakrishnan
Greenhorn

Joined: Jul 30, 2002
Posts: 2
Please go to the following url and download the EJB Work Book for Websphere 4.0.You can find out the solution for the problem u have mentioned.
http://www.store.yahoo.com/titan-books/download.html
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: very very urgent...pl respond..