File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Websphere and the fly likes service specific error 10 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "service specific error 10" Watch "service specific error 10" New topic
Author

service specific error 10

prashanth nagaraj
Ranch Hand

Joined: Mar 11, 2002
Posts: 43
Hi Websphere AppServer Users/Administrators,
version 3.5
When I try to start IBM Admin Server from services , I get this error
" The IBM Admin Server service returned service specific error 10 " , Most of the guys in my team are also getting the same error, we either restart the system or re-install the websphere itself. We are wasting lot of time for this.
If anyone knows answer, kindly reply , so that it would be very helpful for us.
Thanks


regards,<br />prashanth nagaraj
Matthew X. Brown
Ranch Hand

Joined: Nov 08, 2000
Posts: 165
Try this- go to taskmgr for 2000/NT, click on the processes tab, sort based on name. Try to delete all of the java.exe processes that are running. Some of them will say "Access Denied".
The other thing you can do, is that if you have stale database connections, you can get a server specific error ten. You can check on your WAS/logs/tracefile to see if there is any logging. Basically I restart my DB2 services to clear this one from occurring.
Paul Stevens
Ranch Hand

Joined: May 17, 2001
Posts: 2823
We got the same error when installing on a different server. We were told to use a different DB2 service pack. We used service pack 8. Haven't had a problem since.
james edwin
Ranch Hand

Joined: Nov 22, 2001
Posts: 393
hi Prashanth Nagaraj,
The reason u r getting this error is WAS is not able to connect to it's repository. See there r can n number of reason for this.
01) Look into file called <Root _directory> \WebSphere\AppServer\binD:\WebSphere\AppServer\bin\admin.config .
Check username for connecting to Database is correct and all other database setting r correct.
02) Have u created proper user with all previliges,before installing WAS.
03) check <root_directory>WebSphere\AppServer\logs\wssetup.log ,look is there is any error in that .
04) <root_directory>WebSphere\AppServer\logs\tracefile
Look into this file,what error u get.
I am staying in New Delhi(India),if u r also from same part,then we can discuss this on phone. Catch me at deepak901@indiatimes.com
All the best.Pls so post the status on installation.
James Edwin
[ April 03, 2002: Message edited by: james edwin ]

Regards,
James
prashanth nagaraj
Ranch Hand

Joined: Mar 11, 2002
Posts: 43
I upgraded to Websphere 4.0 , the problem I had was in Websphere 3.5 version
Thanks for all for their suggestions
prashanth
Steve Granton
Ranch Hand

Joined: Jan 13, 2002
Posts: 200
Hi,
We have also experienced a lot of related problems with WAS 3.5. We frequently encountered the Error 10 and also had problems with WAS max'ing out the CPU on Windows NT.
In my experience Error 10 is used as a none-specific catch all error code caused by a number of different faults - from not having the correct username/password to start the WAS Admin Server to problems connecting to the repository.
The second problem appears to be caused by a corruption of the repository that WAS uses. In our case we had opted for using the InstantDB provided rather than DB2. As far as I'm aware this InstantDB is a simple flat file database (someone may correct me) and was corrupted frequently. We found the solution was to make a copy of the %WAS_HOME%/bin/idbStore directory immediately after install. Then if the problem occurs you can shutdown the service, remove the corrupted database folder and replace it with a copy of the good idbStore.
To be honest we've found Websphere 3.5 such a difficult product to use (including the slow GUI) when compared to the other servers on the market.
I hope this helps.
Thanks,
Steve
[ April 09, 2002: Message edited by: Steve Granton ]
 
 
subject: service specific error 10