aspose file tools*
The moose likes Websphere and the fly likes very urgent...websphere 4.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "very urgent...websphere 4.0 " Watch "very urgent...websphere 4.0 " New topic
Author

very urgent...websphere 4.0

seradmin
Greenhorn

Joined: Mar 14, 2002
Posts: 14
hi...all..
i want to run my application in websphere 4.0 aes.i have only websphere 4.0 AES i dont have visulagae or websphere studio.i have few jars in my application and few javaclasses which are used by myapplication.in the web side i have jsps,htmls,etc..
i dont have single servlet.as of now we r working woth weblogic.just week back we have moved to websphere4.0.could u pl tell me the process how to run my application in websphere 4.0?
i am trying for the last week but iam getting lot of problems.here i have ejb1.1 spec jars with me.iam able to deploy these jars in webpsher.and iam able to start my applcation in console also.i have configured the database as oracle 8.
could u pl keep all in mind and suugest me the way.i have only websphere 4.0 aes with me.i have created all modules in AAT.
i got frustarted with lot of bugs in my trail.so could u pl keep my problem and suugest me pl?waiting for ur reply..
iam good in doing with weblogic 6.1 .i dont know why these bugs r coming?i have referd evry thing in websphere 4.0 release notes also.and i have fallowed the steps same as in release notes.
but when iam trying to run my application iam getting java.lang.Exception.
i had gone through ur article but u have given the way fro devoloping applications using visual age.so could u suugest me the way without visual age?
thx..
seradmin
pjoisha
Ranch Hand

Joined: Mar 06, 2001
Posts: 123
Why did you decide to move away from Weblogic 6.1?
PJ
mustang india
Ranch Hand

Joined: Feb 05, 2002
Posts: 60
Hey guys,
I have the same problem. My applications run very smoothly on weblogic 7.0 but when I try to run them on WAS they are a gone case.
Hi seradmin, presently I am using ANT utility to generate DD of weblogic. Is there any better tool available?
Thanks in advance,
Mustang.
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
Could you post the exact error that you're seeing? We need more information to help you with your problem.
Kyle


Kyle Brown, Author of Persistence in the Enterprise and Enterprise Java Programming with IBM Websphere, 2nd Edition
See my homepage at http://www.kyle-brown.com/ for other WebSphere information.
Shibin Raghavan
Greenhorn

Joined: Mar 29, 2001
Posts: 11
Even I too am facing the same problem. So, Mustang could u plzzz tell me something abt this ANT tool.
Regards,
Shibin
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..Kyle..
really iam in big trouble.this is the error iam getting when i tried to invoke my jsp from my welcome page login.htm,i have to get ApplicationAreas.jsp after my login ,but iam getting this error.as u asked me to send log...here iam sending log.so pl respond on this.really i got strucked since long back..expecting help from ur end.my classes r in ezc package..
my error is:
-----------
Original Exception:
Error Message: ezc/session/EzSession
Error Code: 500
Target Servlet: null
Error Stack:
java.lang.Exception: ezc/session/EzSession
at ApplicationAreas_jsp_0._jspService(ApplicationAreas_jsp_0.java:184)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:139)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at org.apache.jasper.runtime.JspServlet$JspServletWrapper.service(JspServlet.java:286)
at org.apache.jasper.runtime.JspServlet.serviceJspFile(JspServlet.java:415)
at org.apache.jasper.runtime.JspServlet.service(JspServlet.java:544)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.ibm.servlet.engine.webapp.StrictServletInstance.doService(ServletManager.java:827)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet._service(StrictLifecycleServlet.java:159)
at com.ibm.servlet.engine.webapp.IdleServletState.service(StrictLifecycleServlet.java:286)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet.service(StrictLifecycleServlet.java:106)
at com.ibm.servlet.engine.webapp.ServletInstance.service(ServletManager.java:472)
at com.ibm.servlet.engine.webapp.ValidServletReferenceState.dispatch(ServletManager.java:1012)
at com.ibm.servlet.engine.webapp.ServletInstanceReference.dispatch(ServletManager.java:913)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.handleWebAppDispatch(WebAppRequestDispatcher.java:499)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.dispatch(WebAppRequestDispatcher.java:278)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.forward(WebAppRequestDispatcher.java:105)
at com.ibm.servlet.engine.srt.WebAppInvoker.doForward(WebAppInvoker.java:67)
at com.ibm.servlet.engine.srt.WebAppInvoker.handleInvocationHook(WebAppInvoker.java:123)
at com.ibm.servlet.engine.invocation.CachedInvocation.handleInvocation(CachedInvocation.java:67)
at com.ibm.servlet.engine.srp.ServletRequestProcessor.dispatchByURI(ServletRequestProcessor.java:122)
at com.ibm.servlet.engine.oselistener.OSEListenerDispatcher.service(OSEListener.java:315)
at com.ibm.servlet.engine.http11.HttpConnection.handleRequest(HttpConnection.java:60)
at com.ibm.ws.http.HttpConnection.readAndHandleRequest(HttpConnection.java:313)
at com.ibm.ws.http.HttpConnection.run(HttpConnection.java:242)
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:122)

Error Page Exception:
Error Message: Servlet Not Found: Error
Error Code: 404
Target Servlet: InvokerServlet
Error Stack:
com.ibm.servlet.engine.webapp.WebAppErrorReport: Servlet Not Found: Error
at com.ibm.servlet.engine.webapp.WebAppDispatcherResponse.sendError(WebAppDispatcherResponse.java:97)
at com.ibm.servlet.engine.webapp.InvokerServlet.service(InvokerServlet.java:289)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.ibm.servlet.engine.webapp.StrictServletInstance.doService(ServletManager.java:827)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet._service(StrictLifecycleServlet.java:159)
at com.ibm.servlet.engine.webapp.IdleServletState.service(StrictLifecycleServlet.java:286)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet.service(StrictLifecycleServlet.java:106)
at com.ibm.servlet.engine.webapp.ServletInstance.service(ServletManager.java:472)
at com.ibm.servlet.engine.webapp.ValidServletReferenceState.dispatch(ServletManager.java:1012)
at com.ibm.servlet.engine.webapp.ServletInstanceReference.dispatch(ServletManager.java:913)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.handleWebAppDispatch(WebAppRequestDispatcher.java:499)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.dispatch(WebAppRequestDispatcher.java:278)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.include(WebAppRequestDispatcher.java:111)
at com.ibm.servlet.engine.webapp.WebApp.sendError(WebApp.java:620)
at com.ibm.servlet.engine.webapp.WebApp.sendError(WebApp.java:546)
at com.ibm.servlet.engine.srt.WebAppInvoker.doForward(WebAppInvoker.java:92)
at com.ibm.servlet.engine.srt.WebAppInvoker.handleInvocationHook(WebAppInvoker.java:123)
at com.ibm.servlet.engine.invocation.CachedInvocation.handleInvocation(CachedInvocation.java:67)
at com.ibm.servlet.engine.srp.ServletRequestProcessor.dispatchByURI(ServletRequestProcessor.java:122)
at com.ibm.servlet.engine.oselistener.OSEListenerDispatcher.service(OSEListener.java:315)
at com.ibm.servlet.engine.http11.HttpConnection.handleRequest(HttpConnection.java:60)
at com.ibm.ws.http.HttpConnection.readAndHandleRequest(HttpConnection.java:313)
at com.ibm.ws.http.HttpConnection.run(HttpConnection.java:242)
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:122)
seradmin
Greenhorn

Joined: Mar 14, 2002
Posts: 14
hi..Kyle..
really iam in big trouble.this is the error iam getting when i tried to invoke my jsp from my welcome page login.htm,i have to get ApplicationAreas.jsp after my login ,but iam getting this error.as u asked me to send log...here iam sending log.so pl respond on this.really i got strucked since long back..expecting help from ur end.my classes r in ezc package..
my error is:
-----------
Original Exception:
Error Message: ezc/session/EzSession
Error Code: 500
Target Servlet: null
Error Stack:
java.lang.Exception: ezc/session/EzSession
at ApplicationAreas_jsp_0._jspService(ApplicationAreas_jsp_0.java:184)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:139)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at org.apache.jasper.runtime.JspServlet$JspServletWrapper.service(JspServlet.java:286)
at org.apache.jasper.runtime.JspServlet.serviceJspFile(JspServlet.java:415)
at org.apache.jasper.runtime.JspServlet.service(JspServlet.java:544)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.ibm.servlet.engine.webapp.StrictServletInstance.doService(ServletManager.java:827)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet._service(StrictLifecycleServlet.java:159)
at com.ibm.servlet.engine.webapp.IdleServletState.service(StrictLifecycleServlet.java:286)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet.service(StrictLifecycleServlet.java:106)
at com.ibm.servlet.engine.webapp.ServletInstance.service(ServletManager.java:472)
at com.ibm.servlet.engine.webapp.ValidServletReferenceState.dispatch(ServletManager.java:1012)
at com.ibm.servlet.engine.webapp.ServletInstanceReference.dispatch(ServletManager.java:913)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.handleWebAppDispatch(WebAppRequestDispatcher.java:499)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.dispatch(WebAppRequestDispatcher.java:278)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.forward(WebAppRequestDispatcher.java:105)
at com.ibm.servlet.engine.srt.WebAppInvoker.doForward(WebAppInvoker.java:67)
at com.ibm.servlet.engine.srt.WebAppInvoker.handleInvocationHook(WebAppInvoker.java:123)
at com.ibm.servlet.engine.invocation.CachedInvocation.handleInvocation(CachedInvocation.java:67)
at com.ibm.servlet.engine.srp.ServletRequestProcessor.dispatchByURI(ServletRequestProcessor.java:122)
at com.ibm.servlet.engine.oselistener.OSEListenerDispatcher.service(OSEListener.java:315)
at com.ibm.servlet.engine.http11.HttpConnection.handleRequest(HttpConnection.java:60)
at com.ibm.ws.http.HttpConnection.readAndHandleRequest(HttpConnection.java:313)
at com.ibm.ws.http.HttpConnection.run(HttpConnection.java:242)
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:122)

Error Page Exception:
Error Message: Servlet Not Found: Error
Error Code: 404
Target Servlet: InvokerServlet
Error Stack:
com.ibm.servlet.engine.webapp.WebAppErrorReport: Servlet Not Found: Error
at com.ibm.servlet.engine.webapp.WebAppDispatcherResponse.sendError(WebAppDispatcherResponse.java:97)
at com.ibm.servlet.engine.webapp.InvokerServlet.service(InvokerServlet.java:289)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.ibm.servlet.engine.webapp.StrictServletInstance.doService(ServletManager.java:827)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet._service(StrictLifecycleServlet.java:159)
at com.ibm.servlet.engine.webapp.IdleServletState.service(StrictLifecycleServlet.java:286)
at com.ibm.servlet.engine.webapp.StrictLifecycleServlet.service(StrictLifecycleServlet.java:106)
at com.ibm.servlet.engine.webapp.ServletInstance.service(ServletManager.java:472)
at com.ibm.servlet.engine.webapp.ValidServletReferenceState.dispatch(ServletManager.java:1012)
at com.ibm.servlet.engine.webapp.ServletInstanceReference.dispatch(ServletManager.java:913)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.handleWebAppDispatch(WebAppRequestDispatcher.java:499)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.dispatch(WebAppRequestDispatcher.java:278)
at com.ibm.servlet.engine.webapp.WebAppRequestDispatcher.include(WebAppRequestDispatcher.java:111)
at com.ibm.servlet.engine.webapp.WebApp.sendError(WebApp.java:620)
at com.ibm.servlet.engine.webapp.WebApp.sendError(WebApp.java:546)
at com.ibm.servlet.engine.srt.WebAppInvoker.doForward(WebAppInvoker.java:92)
at com.ibm.servlet.engine.srt.WebAppInvoker.handleInvocationHook(WebAppInvoker.java:123)
at com.ibm.servlet.engine.invocation.CachedInvocation.handleInvocation(CachedInvocation.java:67)
at com.ibm.servlet.engine.srp.ServletRequestProcessor.dispatchByURI(ServletRequestProcessor.java:122)
at com.ibm.servlet.engine.oselistener.OSEListenerDispatcher.service(OSEListener.java:315)
at com.ibm.servlet.engine.http11.HttpConnection.handleRequest(HttpConnection.java:60)
at com.ibm.ws.http.HttpConnection.readAndHandleRequest(HttpConnection.java:313)
at com.ibm.ws.http.HttpConnection.run(HttpConnection.java:242)
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:122)

thx..waiting for ur response..
seradmin
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
Sorry, I haven't check JR in a couple of days. OK, let's focus on your particular problem:
Error Stack:
java.lang.Exception: ezc/session/EzSession
at ApplicationAreas_jsp_0._jspService(ApplicationAreas_jsp_0.java:184)
What this is saying is that the jspservice method of your JSP is throwing an exception at line 184. What's more, it appears to be a raw "Exception" rather than a particular type of an exception. That leads me to believe that it's something you're doing in your application code rather than something that WebSphere is causing.
I would do the following. In this thread I discuss how to keep the generated Java code for your JSP's. Set that setting in the ibm-web-ext.xml file in your WAR file and redeploy the WAR. Then run the problem and open up the corresponding Java file with an editor and find out what code is at and around line 184. If you want to post that excerpt if that doesn't help you, that's fine.
Kyle
seradmin
Greenhorn

Joined: Mar 14, 2002
Posts: 14
hi..kyle..
i did the process what u suggested me.now my ibm-web-ext.xmi is with keep generated value as true.i did this through AAT,and i have redeployed total ear .but still iam getting the same error what i posted u in the earlier.
ok..if u want to see my ApplicationAreas.jsp..here is my code..
but the log is same as before..
here is my jsp:
page import = "ezc.ezparam.EzLogonStatus"
page import = "ezc.ezcommon.EzGlobalConfig"
page import="ezc.ezparam.ReturnObjFromRetrieve"
jsp:useBean id="Session" class="ezc.session.EzSession" scope="session"
jsp:useBean

System.out.println("@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@Session Object is......................"+Session);
//System.out.println("I am in iconfirm");
response.setHeader("Pragma", "No-cache");
response.setDateHeader("Expires", 0);
response.setHeader("Cache-Control", "no-cache");
System.out.println("System number is : " + POsysType);
ezc.session.EzLogonStructure logs = new ezc.session.EzLogonStructure();
String userId = request.getParameter( "username" );
String passWord = request.getParameter( "password" );
String language = request.getParameter( "Language" );
session.putValue("userid",userId);
if(userId != null){
userId = userId.toUpperCase();
}
we need not set the user group
//logs.setUserGroup("555");
logs.setUserId(userId);
logs.setPassWd(passWord);
// logs.setConnGroup("555");
logs.setConnGroup("555");
ezc.ezparam.EzLogonStatus LogonStatus = (ezc.ezparam.EzLogonStatus)Session.logon(logs);
ReturnObjFromRetrieve retLog= LogonStatus.getUserInfo();
System.out.println("User info is.......................");
System.out.println(retLog.toEzcString());
System.out.println("User info Over.......................");
Check for logon status
if ( LogonStatus.IsSuccess())
{
//Redirect to our index page
// response.sendRedirect("../EzCommerce/service/service1/jsps/misc/menuframeset.jsp");
response.sendRedirect("Applications.jsp");
}
else
{
//Redirect to Error/Login Retry Page
response.sendRedirect("loginerror.jsp");
}
----
really i got frustrated with these problems.so pl suggest me..kyle..
really i need ur help..i am in uncertain situation..
waiting for ur response..
thx..
sesradmin
seradmin
Greenhorn

Joined: Mar 14, 2002
Posts: 14
hi..kyle..
i did the process what u suggested me.now my ibm-web-ext.xmi is with keep generated value as true.i did this through AAT,and i have redeployed total ear .but still iam getting the same error what i posted u in the earlier.
ok..if u want to see my ApplicationAreas.jsp..here is my code..
but the log is same as before..
here is my jsp:
page import = "ezc.ezparam.EzLogonStatus"
page import = "ezc.ezcommon.EzGlobalConfig"
page import="ezc.ezparam.ReturnObjFromRetrieve"
jsp:useBean id="Session" class="ezc.session.EzSession" scope="session"
jsp:useBean

System.out.println("@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@Session Object is......................"+Session);
//System.out.println("I am in iconfirm");
response.setHeader("Pragma", "No-cache");
response.setDateHeader("Expires", 0);
response.setHeader("Cache-Control", "no-cache");
System.out.println("System number is : " + POsysType);
ezc.session.EzLogonStructure logs = new ezc.session.EzLogonStructure();
String userId = request.getParameter( "username" );
String passWord = request.getParameter( "password" );
String language = request.getParameter( "Language" );
session.putValue("userid",userId);
if(userId != null){
userId = userId.toUpperCase();
}
we need not set the user group
//logs.setUserGroup("555");
logs.setUserId(userId);
logs.setPassWd(passWord);
// logs.setConnGroup("555");
logs.setConnGroup("555");
ezc.ezparam.EzLogonStatus LogonStatus = (ezc.ezparam.EzLogonStatus)Session.logon(logs);
ReturnObjFromRetrieve retLog= LogonStatus.getUserInfo();
System.out.println("User info is.......................");
System.out.println(retLog.toEzcString());
System.out.println("User info Over.......................");
Check for logon status
if ( LogonStatus.IsSuccess())
{
//Redirect to our index page
// response.sendRedirect("../EzCommerce/service/service1/jsps/misc/menuframeset.jsp");
response.sendRedirect("Applications.jsp");
}
else
{
//Redirect to Error/Login Retry Page
response.sendRedirect("loginerror.jsp");
}
----
actually that one is .jsp.but i have removed all tgas to post u the code.if i posted the jsp with tags javaranch is giving problemso i have removed all tags to post u(this is for posting purpose only)
really i got frustrated with these problems.so pl suggest me..kyle..
really i need ur help..i am in uncertain situation..
waiting for ur response..
thx..
sesradmin
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
No, I didn't want to see your JSP -- I wanted to see the Java code that is generated from your JSP when WebSphere compiles it. When you set the keepgenerated tag to true the Java source code will be kept in a subdirectory. Do a search for ApplicationAreas_jsp_0 (the last digit may change, so search for 1..9 as well) on your hard drive and then post the code around line 184 of that.
Kyle
mustang india
Ranch Hand

Joined: Feb 05, 2002
Posts: 60
Hi shibin,
ant is the tool provided by weblogic to generate DD for the war and jar files, the basic skeleton DD just enough to run the app.
First u have to set the enviromnet. It would typically in c:\bea\wlserver7.0\config\mydomain\setenv.bat
if u have ur source code and jsp in c:\test\wljsp, goto c:\test and run the command
java weblogic.ant.taskdefs.war.DDInit <dirname, in this case wljsp>
this will generate DD for the war files.
java weblogic.ant.taskdefs.ejb.DDInit <dirname, in this case wljsp>
this will generate DD for the ejb jar files.
Hope this will help you.
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..kyle..
for my applicationAreas.jsp I didn't found .java file. just I am getting .dat file so, what will be the mistake I did?
If u inform me the reason, I'll rectify it and I'll send u the .java file..
ofcourse I have generated keepgenerated tag =true but I am not getting .java file.
so please suggest me in this..
thx.
seradmin
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..kyle..
could u pl respond?on my last query?
thx..
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
Rajaram, I don't know why you can't find the Java file. From your first error it appears that your JSP is compiled properly into a .java file and then a .class file, but when you add keepgenerate=true and redeploy the WAR file (which you did, right?) it should have then started to keep the .java files around after the next server restart...
Kyle
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi...kyle..
really iam sorry for troubling u.even today also i tried to generate .java file for my jsp but i coudnt.really iam in very bad situation.today i have rebuild the total ear and i have installed my ear.but iam not fiding .java file for jsp,even i kep keepgenerated as true.if u dont mind coud u explain me the process how to run hello program in websphere 4.0 aes with my environment.as i told u in the earlier i dont have visulaage or websphere studio.just i have AAT and websphere4.0 aes.pl help me in this reagard.really i got frustrated with these problems.if u can send the code for hello it'll be well and good for me..
pl write me some thing back...i'll very much greatful for ur help till now..
thx..
rajaram
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
Rajaram, there is a tutorial supplied with WebSphere -- just read the infocenter. Also, another good resource is the WebSphere 4.0 Development Handbook Redbook that also walks you through the process.
Kyle
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..kyle..thx for responding intime.
ok..will the websphere 4.0 handbook will work for me?imean as i told u i want to devolop my application with websphere4.0aes and AAT only.i dont have visual age or studio.just now i have gone through the handbook.it seems in contents he has given devolopment using studio and visual age.so could u write me will it work out for me?
can i devolop my app using websphere 4.0 aes without studio and visula age?so pl write me some thing back on these.
thx..
rajaram
Mike Jones
Ranch Hand

Joined: Dec 12, 2001
Posts: 109
Raj,
I'm not Kyle, but I can give you some input about the handbook. I'm currently going thru the handbook (about 2/3 thru it). The handbook covers compiling, packaging and deploying using Ant in conjunction with WebSphere's AAT, ejbdeploy and SEAppInstall (i.e. VA and WSAD not required).
Mike


<BR>
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
Originally posted by rajaram:
hi..kyle..thx for responding intime.
ok..will the websphere 4.0 handbook will work for me?imean as i told u i want to devolop my application with websphere4.0aes and AAT only.i dont have visual age or studio.just now i have gone through the handbook.it seems in contents he has given devolopment using studio and visual age.so could u write me will it work out for me?
can i devolop my app using websphere 4.0 aes without studio and visula age?so pl write me some thing back on these.
thx..
rajaram

Just because the handbook mentions WSAD and VAJ doesn't mean it REQUIRES WSAD and VAJ. Read it -- it talks about development and deployment without these tools as well.
Kyle
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..kyle..
today i tried with creating modules and installing as for the process mentioned in handbook.but still iam getting same prob.i dont know why iam troubling this much with this .really iam in ver very bad situation.really iam on the way to quit from webshere.ok...could u pl suggest me.already two moths gone with this.
thx..
rajaram
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..kyle..
could u pl respond .....so that i can move forward..
thx..
rajaram
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..kyle..
it seems ur busy.could pl respond if u find time.iam waiting for ur suggestion..

thx..
rajaram
seradmin
Greenhorn

Joined: Mar 14, 2002
Posts: 14
hi..all..
it seems kyle is busy.so does any body cAN RESPOND ON THIS?
THX..
RAJA
Simon Song
Ranch Hand

Joined: Feb 01, 2002
Posts: 217
First, have you got basic websphere samples running happily in your environment?
Have you tried the http://host:9080/webapp/examples, and execute some samples there?
Second, you don't need VAJ or WSAD to develop for WAS. Here we use JBuilder, and SlickEdit. You can use AAT to set WAS's own DD information.
Third, which WAS do you have 4.0? 4.0.1? or 4.0.2? Make sure your problem is not part of 4.0.2 fixes, if so you have to upgrade to 4.0.2.
Some useful links:
http://www14.software.ibm.com/webapp/download/product.jsp?cat=&s=p&id=TDUN-49EVRT&pf=&presb=&type=s&postsb=v
And all knows WAS issues:
http://www-1.ibm.com/support/manager.wss?rs=180&rt=3&navkey=2ByDocumentCategory&path=Category%3DAPAR+%28Authorized+Program+Analysis+Report%29%06Product+Group%3DSoftware%06Product+F amily%3DWeb+Application+Servers%06Product+Type%3DWebSphere+Application+Server
Forth, let's adopt divide and command methodology for your issues. Keep simple stuffs running, my point is can you have a very simple JSP(hello.jsp) can be forwarded from your own login page? And when your complex JSP refers other Java objects, are these objects in your WAR? or available in WAS classpath? Java Classloader issue is the most common problems in JSP failure, it cannot find the Java Objects referred in your JSP.
Don't get scared, and be confident. No other people in the forum is totally blocked by WAS so far, so you can trust WAS is a workable product.


Simon Song
Certified Entperise Developer of Websphere
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..simon song nad kyle..
today itried with the urls u mentioned.but iam not able to do.still iam getting the above error wht i posted in the earlier.really i have used efix patch also.really iam in very bad situation.ok can u suugest me new version of server .so that i can quit away from 4.0.1 AEs and start working on that .here i have ejb 1.1 spec jars .at any cost i have to run my application by next week end.so could u mind pl respond...really iam very much greatful about u r help..
thx..
rajaram
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..simsong..
i forgot to tell u one thing.iam able to run sample applications,which r given by websphere.
so pl help me out..
thx..
rajaram
Simon Song
Ranch Hand

Joined: Feb 01, 2002
Posts: 217
You mean you have issues in invoking EJB from JSP? Have you tried to change your "Module Visibility" from "Module" to "Application" for the Application Server your code is deployed in?
And you may consider migrate to 4.0.2 with FP2 from the above URL.
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..song..
thx for rsponding.could u pl tell me the url about 4.0.2 fp2 where can i down load it?pl respond ..
thank u veru much for ur guidence..
rajaram
Simon Song
Ranch Hand

Joined: Feb 01, 2002
Posts: 217
http://www14.software.ibm.com/webapp/download/product.jsp?cat=&s=p&id=TDUN-49EVRT&pf=&presb=&type=s&postsb=v

Look for Fixpack2 for WAS4.0
rajaram
Ranch Hand

Joined: Mar 23, 2002
Posts: 45
hi..song..
really iam very very thx for ur guidence.today i found the download link.i'll start download today and i'll write u remaing things tomarrow..expecting ur cooperation in future..
thx very much..
rajaram
Simon Song
Ranch Hand

Joined: Feb 01, 2002
Posts: 217
Please open a new thread for your issue, this thread is too full!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: very urgent...websphere 4.0