• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

I am wondering why IBM Websphere Application Developer can not support MDB and EJB QL

 
jeffrey z. lee
Ranch Hand
Posts: 40
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
 
Rahul Mahindrakar
Ranch Hand
Posts: 1868
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
IBM was supports J2EE 1.2 and MDB (but perhaps not EJB QL) is a part of J2EE 1.3. Thus the lack of support. However I think IBM WAS new version is going to support MDB.
 
Kyle Brown
author
Ranch Hand
Posts: 3892
5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, Rahul has got it. WSAD 4.0X supports EJB 1.1, not EJB 2.0. WSAD 5.X (out this summer) will support EJB 2.0.
Kyle
 
jeffrey z. lee
Ranch Hand
Posts: 40
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
websphere lags behind JBuilder in supporting EJB 2.0
 
Steve Long
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Actually WSAD does support a version of EJB QL, it is modified for EJB 1.1 and WebSphere. If you have the product you can do a search in the Help Perspective for "EJB Query Language" for details.
Steve
 
Simon Song
Ranch Hand
Posts: 217
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you have real interest in the coming WAS5.0, you can ask IBM sales rep to participate in WAS5 beta program then you will get WSAD 5.0,
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic