Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

how to start IBM web server????

 
Seenu Reddy
Ranch Hand
Posts: 108
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi all,
i deployed bean in the websphere4.0. its deployed fine. with thin client i am able to communicate with the bean. but through web i am not able to communicate the bean. because port 9080 is not listining...for that i have to start web server. how can i start the webserver. by defaultly is it(webserver) starts with application server. if in my case it is not starting.
so how can i start the webserver manually.
thanks.
regards
seenu
 
Tualha Khan
Ranch Hand
Posts: 287
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
try starting the ibm http server from the start menu, if you are using it!
or you can give the following command on the command line:
net start "IBM HTTP Server"
Bye,
Tualha Khan
 
Seenu Reddy
Ranch Hand
Posts: 108
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tualha Khan,
thanks. i installed only websphere4.0 server. not ibm web server. do i install web server separately or automatically it will install with application server. if not how to configure web server with application server...

regards,
seenu
 
Tualha Khan
Ranch Hand
Posts: 287
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What version (alongwith the edition) are you using?
Also, did the server installation program give you an option to choose the webserver to be used along with WAS?
Bye,
Tualha Khan
 
Mike Jones
Ranch Hand
Posts: 109
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Seenu,
Note: the embedded HTTP server is automatic with the startup of WAS 4.0 (i.e. you do not start it and stop it manually. As far as I know, you can't even do this with the embedded server).
The internal (embedded) HTTP server is automatically part of the WebSphere Application Server (i.e. not a seperate install). The IBM HTTP Server is the external one, which uses the plugin-cfg.xml. You don't need to mess with the external HTTP server with AEs for development ... and learning.
Can you run the admin console. /localhost:9090/admin
If so, I bet your problem is a jsp or servlet mapping problem for your application.
[ May 14, 2002: Message edited by: Mike Jones ]
 
Seenu Reddy
Ranch Hand
Posts: 108
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Mike Jones,
thanks for ur replay,
while instalation WAS4.0 i selected the IBM HTTP server. the installation was successfully...
i am able to get the admin console using http://localhost:9090/admin. but the web server port not in use...that is when i give url http://localhost:9080/...i am getting page not found error...for this,webserver has to run with application server...
to run webserver what should i do....
thanks in advance...
regards
seenu
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic