This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes Websphere and the fly likes Configuration of SQL Server 7.0 in Websphere 4.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Configuration of SQL Server 7.0 in Websphere 4.0" Watch "Configuration of SQL Server 7.0 in Websphere 4.0" New topic
Author

Configuration of SQL Server 7.0 in Websphere 4.0

Ather Naqvi
Greenhorn

Joined: Nov 04, 2001
Posts: 11
I would be thankful to anybody telling me how to configure SQL Server 7.0 in webSphere 4.0. I have been trying this for two days but reamin unsuccesful.
xavirm
Greenhorn

Joined: Jun 20, 2002
Posts: 9
Hi, have you solved it ?
I have WAS 3.5 but I cannot have it working SQL Server 7.0.
In VAJ 3.5 everything works fine.
I really appreciate yopur help.
Thanks in advance.
Simon Song
Ranch Hand

Joined: Feb 01, 2002
Posts: 217
Don't understand your problem, you neeed a JDBC driver for SQLServer 7. WAS comes with merant driver, just use that to configure the datasource.


Simon Song
Certified Entperise Developer of Websphere
xavirm
Greenhorn

Joined: Jun 20, 2002
Posts: 9
Excuse me,Simon Song.
Are you telling that WAS 3.5 comes with a Merant (Data Direct) jdbc driver for SQL Server 7.0 ?
I'm experiencing problems when I try to use the jdbc/odbc bridge.
Kile Brown said in another post that jdbc/odbc bridge is not supported by WAS 3.5 AND VAJ 3.5, but I have my VAJ 3.5 Application running smoothly.
The problem comes when I try to run it on WAS 3.5.
I got the following message :
"Unrecognized database or driver
"sun.jdbc.odbc.JdbcOdbcDriver"; using generic settings"
I don't know how to resolve this. I tough I had to buy a jdbc driver for SQL Server 7.0 if I had received a way to fix this up, but if you know that WAS comes woth a Merant JDBC driver for SQL Server 7.0 this would be great!!
Can you help me telling me where in the setup disks can I find this driver ?
Thanks in advance.
[ June 24, 2002: Message edited by: xavirm ]
xavirm
Greenhorn

Joined: Jun 20, 2002
Posts: 9
Excuse me,Simon Song.
Are you telling that WAS 3.5 comes with a Merant (Data Direct) jdbc driver for SQL Server 7.0 ?
I'm experiencing problems when I try to use the jdbc/odbc bridge.
Kile Brown said in another post that jdbc/odbc bridge is not supported by WAS 3.5 AND VAJ 3.5, but I have my VAJ 3.5 Application running smoothly.
The problem comes when I try to run it on WAS 3.5.
I got the following message :
"Unrecognized database or driver
"sun.jdbc.odbc.JdbcOdbcDriver"; using generic settings"
I don't know how to resolve this. I though I had to buy a jdbc driver for SQL Server 7.0 if I had received a way to fix this up, but if you know that WAS comes woth a Merant JDBC driver for SQL Server 7.0 this would be great!!
Can you help me telling me where in the setup disks can I find this driver ?
Thanks in advance.
Simon Song
Ranch Hand

Joined: Feb 01, 2002
Posts: 217
Yeah, Merant's SequeLink(Type 3) definitely comes with WAS3.5. You should be able to download it from IBM support website.
I don't know where to dl DataDirect(Type 4) driver, but you can try IBM tech support.
JDBC-ODBC bridge has many issues, try avoid it in production environment.
xavirm
Greenhorn

Joined: Jun 20, 2002
Posts: 9
OK, thanks.
I'll try it.
xavirm
Greenhorn

Joined: Jun 20, 2002
Posts: 9
Hi Simon.
I installed the Merant JDBC driver.
But now, I don't get the "Unrecognized database or driver .." message.
I just get a "null:init" message and my browser shows a blank screen.
Do you know waht's happening ?
Best regards.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Configuration of SQL Server 7.0 in Websphere 4.0