aspose file tools*
The moose likes Websphere and the fly likes Remote Admin Console problems --- works locally Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Remote Admin Console problems --- works locally" Watch "Remote Admin Console problems --- works locally" New topic
Author

Remote Admin Console problems --- works locally

Ben Hall
Greenhorn

Joined: Jun 21, 2002
Posts: 2
From a pretty much default install (pretty much being as much as one can be default) of Websphere 4.0.1 updated to 4.0.3 I have been unable to run the Admin console remotely. Whenever I try to run the console with the server ServerName 900 as the argument I receive the error (which has been posted before on this site):
"ADGU2008E: The Administration Client failed to connect to the Administration Server. Start the local or remote Administration Server Service before launching the Administration Client."

I've searched this site for answers and tried to resolve the problem with the solutions others have posted, but no go.
I have also sniffed the network traffic between the two hosts, and there is a connection made on port 900, and others, that stays up for around a minute and a half until the error pops up.
The client works locally with no problems, and the sample servlets work after starting the server from inside the admin console.
Any ideas? I'm very new to websphere and would appreciate any feedback what-so-ever, anything to get this figured out.
Thanks,
Ben Hall
[ June 21, 2002: Message edited by: Ben Hall ]
Simon Song
Ranch Hand

Joined: Feb 01, 2002
Posts: 217
Are you sure your remote client is at the same level (4.0.3)? I don't see any problem here.


Simon Song
Certified Entperise Developer of Websphere
Prachee
Greenhorn

Joined: Jun 13, 2002
Posts: 8
Hi Ben,
I have not used WAS 4.0.1, but I had same problem with WAS 3.5. I install WAS 3.5 and upgrade it to 3.5.5. Once I upgrade it to 3.5.5, the remote admin console doesnt work. U have the similar problem. U have to add the efixes on the remote machine as well to make the admin console work. Then it will work fine.
Regards -
Prachee Orpe
Ben Hall
Greenhorn

Joined: Jun 21, 2002
Posts: 2
RESOLVED.
After sniffing the connection from the remote machine I found the problem. We use a separate private network for backing up our servers. Lately a lot of our new machines have come with a built-in NIC and a second PCI NIC. By default we've been using the built-in nic for the backup network. The built-in always comes up as the first network interface under windows 2000. In the sniffed packet, I found this bit of data:
com.ibm/WsnBootstrap/WsnNameService:1.0... ............... ..192.168.1.38.
This shows that the Admin service just grabs the IP from the first network interface by default. From what I can tell the service passes the location of itself in the first reply packet and in my case that location made no sense and all communcation stopped at that point.
I tried to find out what to specify in the "admin.config" file to change the address but was unsuccessful. I also tried a few guesses, but no go. I ended up just switching the cables and reconfiguring the network connections so the first interface is setup for the outside network and that worked.
Thanks for the replies in any case.
Now, can anyone by any chance tell me how to configure some security on the admin console so the entire universe can't reconfigure the appserver?
I'm going to search around right now.
-Ben
Patrick Finnegan
Ranch Hand

Joined: Mar 05, 2002
Posts: 179
If the machine has two nics then specify the management nic address in the admin.config file.
com.ibm.CORBA.LocalHost=192.168.200.160
Configure WebSphere security in the admin console security center. Select authentication type e.g Local os with valid userid and password. Restart WebSphere to activate security. READ THE WS HANDBOOK before you do this. On restart select security center/administrative roles/admin role/ and assign OS userids and groups(e.g NT userids and groups) to admin function. All this is documented in the handbook.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Remote Admin Console problems --- works locally