File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Websphere and the fly likes JORB0080: Port 9000 is in use. Specify a different port number. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "JORB0080: Port 9000 is in use. Specify a different port number." Watch "JORB0080: Port 9000 is in use. Specify a different port number." New topic
Author

JORB0080: Port 9000 is in use. Specify a different port number.

Arvind Shukla
Ranch Hand

Joined: Jun 26, 2002
Posts: 38
Hi,
I have installed WAS4.0.1 on Windows 2000 Professional. Strangely I get "JORB0080: Port 9000 is in use. Specify a different port number.JORB0080: Port 9000 is in use. Specify a different port number." when I try to start adminserver. I checked services file in the os, none is using 9000 port but still, I don't understand why? Any pointer in this is highly appreciated.
Arvind


Arvind,<br />IBM Certified WAS admin (Test 489, Test 340, Test341)
Bhiku Mhatre
Ranch Hand

Joined: Apr 08, 2002
Posts: 127
Do you have any other WAS(V3.5) still running on the system ?? Alternatively do you have WebSphere Studio running on the system ??
If this is so please close it.


The difference between winner and loser is making things happen and letting things happen.
Sachin Agrawal
Greenhorn

Joined: Jun 27, 2002
Posts: 3
Try to start the admin console at port 9090.
Dharmesh Chheda
Ranch Hand

Joined: May 08, 2001
Posts: 204
Well Bhiku I disagree with you
You cant install WAS 3.5 and WAS 4.0 on the same machine and keep both running .
Secondly can you please explain me why do i have to close Websphere Studio to free the port?. i actually am not aware why it needs to be done.Will be glad if you reply.
Actually port 9000 is used by Location Service Daemon for Naming Services.
Arvind do the following ..
Edit the admin.config file and modify the following parameter
com.ibm.ejs.sm.adminServer.lsdPort=<port>
the <port> is the port number to be used for LSD and then restart the adminServer.
If that parameter is not present then add the whole line and port. then restart
Try this .
]
[ June 27, 2002: Message edited by: Dharmesh Chheda ]

regards,<br />Dharmesh Chheda
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: JORB0080: Port 9000 is in use. Specify a different port number.