• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

can't run struts-example.war in WAS 4.0.3

 
david chan
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I downloaded STRUTS 1.0.2 and try to install the struts-example.war
to WAS 4.0.3 in my w2k box.
First I went to the web admin console and from there go down to
Nodes->myComputerName->Enterprise Applications, then click "install"
button.
In "Application Installation Wizard" page, I select the
struts-example.war in "path" field, and put application name as
"struts-example", context root also "struts-example". then next, then
Finish, and it seems installed successfully.
A new icon "struts-example" appear under "Enterprise Application"
along with others like petstore, sampleApp.
I click the "struts-example", two child icons "Web Modules" and "EJB
Modules" appear, then I click the "Web Modules", the
struts-example.war web module page has a "cannot be run" icon, and I
also try to start, restart it, only get "The WebModule
struts-example.war cannot be run" on the top.
I tried to go to: http://localhost/struts-example/, got http 404 not
found error.
I then check the logs directory, can't find any error log.
I checked the "installedApps" directory, a "struts-example.ear"
directory is created, and then two sub-directory: "META-INF" and
"struts-example.war"
What happen?
Note: my original Websphere is 4.0.1, because I can't run
struts-example, I downloaded the fixpack 3 to upgrade to 4.0.3
David
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic