aspose file tools*
The moose likes Websphere and the fly likes cannot connect to database Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "cannot connect to database" Watch "cannot connect to database" New topic
Author

cannot connect to database

Mike Yu
Ranch Hand

Joined: Nov 17, 2001
Posts: 175
Hi,
I use WCS 5.4 Pro with DB2. All are installed on one machine (Windows 2000 server). It worked very well. But this time, when I started the WAS admin server and checked wcs.log file, there is an error: Failed to connect to the database from the datasource (jdbc/.....).
The DB2 services are OK and I can access DB2 database from DB2 command center from the same computer. But when I tried to access to the database from another computer, I got error: user name or password is incorrect.
I tested the datasource connection from WAS admin console, I got error: Failed to connect to data source. Encountered
COM.ibm.db2.jdbc.DB2Exception: (SQL State: 08004, Error Code: -1403) IBM][CLI Driver] SQL1403N The username and/or password supplied is incorrect. SQLSTATE=08004.

Does any one know what the problem is and how to solve it?
Thanks,
Mike


Thanks,<br />Mike
Nigel Kat
Greenhorn

Joined: Jun 25, 2002
Posts: 16
Check the userid and password that are being passed by your application. The ids that were built into it for your stand-alone application were contained and defined only to the NT system that they lived on. They were not defined and so they don't work on the console, and they won't work in the application deployed to a WAS that is accessing a separate DB2 database.
The DB2 administrator should be able to help you with the correct userid and password that you should be using.
>^..^<
Kat
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: cannot connect to database
 
Similar Threads
jndi issue
WAS failed to start
JDBC Connection to DB2 on OS/390
Not able to config the database!
Problem while connecting to db2