wood burning stoves 2.0*
The moose likes Websphere and the fly likes can't access admin console:password changed Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Websphere
Bookmark "can Watch "can New topic
Author

can't access admin console:password changed

david chan
Ranch Hand

Joined: Jun 10, 2002
Posts: 46
HI,
I have websphere 4.0.3 server running in my win2000. I first setup the admin username and password as OS authorization (that is same as my win2000 login), it works fine.
But a few days before I changed my desktop password because it is expired, and then I can't access websphere admin console because the password store in websphere is different from my desktop login.
What can I do?
Thanks.
David
JeanLouis Marechaux
Ranch Hand

Joined: Nov 12, 2001
Posts: 906
You have to disable the security on your WebSphere manually.

1 - Stop the server
2 - in %WAS%/properties, delete sas.server.props.futur
3 - in %WAS%/properties, change sas.server.props
The line : com.ibm.CORBA.securityEnabled=false
If your repository is stored in DB2 (I guess it could depend on your was version, AE or AES), then modify the DB2 table *ejsadmin_securitycfg_table* :
connect to db2 and use :
db2 update ejsadmin.securitycfg_table set securityenabled=0
Restart the server. The security is desabled
You can now set the security again with the new password.
HTH


/ JeanLouis<br /><i>"software development has been, is, and will remain fundamentally hard" (Grady Booch)</i><br /> <br />Take a look at <a href="http://www.epfwiki.net/wikis/openup/" target="_blank" rel="nofollow">Agile OpenUP</a> in the Eclipse community
david chan
Ranch Hand

Joined: Jun 10, 2002
Posts: 46
I can't find the file "sas.server.props.futur" in my AES 4.0.3. Also the line "com.ibm.CORBA.securityEnabled=false
" is commented out already in sas.server.props
I also check the server-cfg.xml, no such line.
Are you talking different version of websphere server?
Many thanks.
David
david chan
Ranch Hand

Joined: Jun 10, 2002
Posts: 46
Just figure out:
In server-cfg.xml, change the "true" to false.
virtualHosts xmi:id="VirtualHost_2" name="admin_host">
<aliases xmi:id="HostAlias_5" hostname="*" port="9090"/>
</virtualHosts>
<security xmi:id="Security_1" cacheTimeout="30000" enabled="true" activeAuthMechanism="LocalOSAuthentication_1">
David
 
GeeCON Prague 2014
 
subject: can't access admin console:password changed