jQuery in Action, 2nd edition*
The moose likes Websphere and the fly likes Migration from websphere 3.5 to 4.0.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Migration from websphere 3.5 to 4.0.1 " Watch "Migration from websphere 3.5 to 4.0.1 " New topic
Author

Migration from websphere 3.5 to 4.0.1

Prasad P Nair
Greenhorn

Joined: Nov 22, 2002
Posts: 10
Hi all,
I'm a new bie to websphere, and i'm in project to migrate an application from websphere 3.5 to 4.0.1. Application is a simple site with jsp pages. They will be giving me source code. What all should i do to migrate or where can i find the documents for it
Prasad
Eric SIMON
Greenhorn

Joined: Nov 08, 2002
Posts: 7
Hi,
First, the best way is to move to JSP 1.1.
Then to deploy your application, i think you should use Application Assembly Tool to package your JSPs in web module and enterprise application.
It generates an .ear file that you can deploy on WAS.
You can download WAS RedBook at this URL : http://publib-b.boulder.ibm.com/cgi-bin/searchsite.cgi?query=SG246176
Eric.
Joseph Hatton
Greenhorn

Joined: Dec 12, 2002
Posts: 20
This website has wealth of info
www.webspherecentral.com
hope this helps.
Prasad P Nair
Greenhorn

Joined: Nov 22, 2002
Posts: 10
Thanks guys,
I have a new problem now. In my jsp files all resource files(js and images) are given as absolute paths (/images/*.gif;/script/*.js). Now my problem comes when i try to give some context root(say abc). Now instead of pointing to abc/images/*.gif, it's pointing to root/iamges/*.gif. I need to give context root to my application in order to display everything correctly which means i can run only one application. Can anybody help??
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Migration from websphere 3.5 to 4.0.1
 
Similar Threads
monitoring WebSphere performance
Migrating Websphere based J2EE application to SAP Application Server
Logging in JBoss 4.0.1
Need help in Struts Application Migration.
who can brief about WSAD history