This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Agile forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

wsad 5 unable to find recources

martijn van der veek
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I recently switched from wsad 4.0.3 to wsad5 and encountered the following
I have a problem of reading .properties files
I'm working with a web project en the property file is located in de source
directory. When the project is build it is automicaly copied to the output
Problem is in wsad 4.0.3 it worked perfectly and in wsad 5 im getting a
Below are some code fragments of the call to retrieve a string from a
.properties file.
First the structure of my project
- Java source
- Web Content
- classes
- packageX.Y.Z.MyServlet.class
Extra info: I make use of an addition class to extract the string, this
class is called and is located in a utility jar which
is located in the EAR.
Properties prop = System.getProperties();
PropertiesImporter.getPropertyValue("test", "functional.test.url"));
public static String getPropertyValue(String propertyFilename, String
propertyKey) {
try {
} catch (java.util.MissingResourceException e) {
return null;
! IN WSAD4 this code worked.
I hope somebody has an answer for my why this code doesn't work in WSAD5.
With kind regards,
martijn van der Veek
[ March 17, 2003: Message edited by: martijn van der veek ]
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic