aspose file tools*
The moose likes Websphere and the fly likes Non-application exception occurred while processing method add Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Non-application exception occurred while processing method add" Watch "Non-application exception occurred while processing method add" New topic
Author

Non-application exception occurred while processing method add

Karthik Prabu
Ranch Hand

Joined: Dec 27, 2002
Posts: 48
hi All,
I tried deploying a simple stand alone bean without any application. I creted the ejb.jar with the AAT of websphere4.0 and installed thru adminconsole-install enterprise application-standalone module. I tried to access that bean from an external program. I got the following exception
Non-application exception occurred while processing method add: java.lang.IllegalStateException
at com.ibm.ejs.container.StatelessBeanO.getCallerPrincipal(StatelessBeanO.java:474)
at com.arthic.add.AddBean.setSessionContext(AddBean.java:38)
at com.ibm.ejs.container.StatelessBeanO.<init>(StatelessBeanO.java:85)
at com.ibm.ejs.container.CMStatelessBeanO.<init>(CMStatelessBeanO.java:29)
at com.ibm.ejs.container.CMStatelessBeanOFactory.create(CMStatelessBeanOFactory.java:17)
at com.ibm.ejs.container.EJSHome.createBeanO(EJSHome.java:461)
at com.ibm.ejs.container.EJSHome.createBeanO(EJSHome.java:545)
at com.ibm.ejs.container.activator.UncachedActivationStrategy.atActivate(UncachedActivationStrategy.java:66)
at com.ibm.ejs.container.activator.Activator.activateBean(Activator.java:186)
at com.ibm.ejs.container.EJSContainer.preInvoke(EJSContainer.java:1619)
at com.arthic.add.EJSRemoteStatelessAdd.add(EJSRemoteStatelessAdd.java:24)
at com.arthic.add._EJSRemoteStatelessAdd_Tie._invoke(_EJSRemoteStatelessAdd_Tie.java:94)
at com.ibm.CORBA.iiop.ExtendedServerDelegate.dispatch(ExtendedServerDelegate.java:532)
at com.ibm.CORBA.iiop.ORB.process(ORB.java:2395)
at com.ibm.CORBA.iiop.OrbWorker.run(OrbWorker.java:186)
at com.ibm.ejs.oa.pool.ThreadPool$PooledWorker.run(ThreadPool.java:104)
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:138)

But when i tried to acces another bean which is present in an application ( from an .ear file ) it is not throwing any exception.
Please tell me what to do to deploy only ejb in websphere.
Thanks
Karthik
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Non-application exception occurred while processing method add