Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WSAD 5.0 Publishing problem

 
Irene Db
Greenhorn
Posts: 13
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am new to WSAD and I need help.
When I started WebSphere test server, I got this warning:
Publishing: WebSphere v5.0 Server Configuretion
Creating folder .repository
The J2EE projects defined in the server configuration are not consistent with the projects thst exist in the workbench:
The module project "null" in the EAR project "NewsEAR" defines in the server configuration does not exist.
The module project "null" in the EAR project "NewsEAR" defines in the server configuration does not exist.
This problem can be resolved by opening an editor for the server "WebSphere v5.0 Test Environment" or the server configuration "WebSphere v5.0 Server configuration" and then responding Yes to the WebSphere Server Warning window that appears.
I did open an editor for the server "WebSphere v5.0 Test Environment" and responded Yes to the Warning window, but I still have this problem.
Thank you.
[ May 15, 2003: Message edited by: Irene Db ]
 
M Dollenkamp
Greenhorn
Posts: 6
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you added the "NewsEAR" ear project to the testserver you're using in the server view by bringing up the test servers context menu (right mouse click) and clicking add project?
If so you might want to try remove it and adding it again.
If that doesn't work you could try to open the ear deployment discriptor removing the modules (projects) associated with it and then adding them again. Then I'd remove and add the ear to the test server again just in case.
Hope this helps for you;
 
Irene Db
Greenhorn
Posts: 13
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
M Dollenkamp, thank you for your help.
I removed and added again ear project and now it is working!
Thank you!
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic