• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Virtual Host/WebGroup Not Found in wsad 5.0 test environment

 
Arnab Mitra
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,
I am trying to deploy and run a j2ee project using wsad 5.0
The ejb module deploys and runs fine bur while trying to
run the web module as part of a j2ee project i get the
following exception:
Servlet Request Processor Exception: Virtual Host/WebGroup Not Found : The web group / has not been defined
Could anyone please suggest how to solve this problem?
Thanks in advance
-Arnab Mitra
 
Melih Onvural
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Build the project and it should solve the problem.
 
vishwa venkat
Ranch Hand
Posts: 185
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
check the deployment descriptors. possibly rebuilding project may solve the problem.
 
Satish Chilukuri
Ranch Hand
Posts: 266
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There are many reasons for why you that exception. Below are the reasons that I know of, which can cause a "Virtual Host/WebGroup Not Found" exception.

1. The context name/path is wrongly given while trying to access a resource from your webpage(ex: images/javascript files).

2. If your Virtual Host mapping is wrong (if you are using virtual hosts). Actually I have never worked with that option. Found that this too might be a reason when I googled for the problem.

3. If your server didn't start properly. We once had an exception while starting the server. Our ejbs weren't properly deployed and that throwed an exception. When we tried to run our web app, we got the Virtual host exeption.
 
Arnab Mitra
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The problem at that time (if I remember correctly) of course was that the Virtual Host with path was not defined at all. Defining that had solved the problem.
 
Mathew Sam
Ranch Hand
Posts: 124
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How do you do it?
 
Arnab Mitra
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
One way to define Virtual Hosts is through the administrative console (wsadmin)
This might be of some help:
http://publib.boulder.ibm.com/infocenter/wasinfo/v5r1//index.jsp?topic=/com.ibm.websphere.base.doc/info/aes/ae/trun_app_instwiz.html

Cheers

-Arnab
 
Fabrizio Castrotorres
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There is one file that contains the virtual host mapping "ibm-web-bnd.xmi".
This should be in the same location as your "web.xml"

The contents look somewhat like this:

<?xml version="1.0" encoding="UTF-8"?>
<webappbnd:WebAppBinding xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns:webappbnd="webappbnd.xmi" xmi:id="WebAppBinding_1" virtualHostName="default_host">
<webapp href="WEB-INF/web.xml#WebApp"/>
</webappbnd:WebAppBinding>


"virtualHostName" points to the virtual host defined. Generally if you have virtual host be "default_host" on your websphere studio environment it should work. This value can be different if you copied this WAR file from a development server. When you deploy it, you may need to change it as well. I hope this helps.

-Fabrizio

[ June 23, 2006: Message edited by: Fabrizio Castrotorres ]

[ June 23, 2006: Message edited by: Fabrizio Castrotorres ]
[ June 23, 2006: Message edited by: Fabrizio Castrotorres ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic