File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Websphere and the fly likes Transaction Times Out after 120 seconds in Session Bean Operation Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Transaction Times Out after 120 seconds in Session Bean Operation" Watch "Transaction Times Out after 120 seconds in Session Bean Operation" New topic
Author

Transaction Times Out after 120 seconds in Session Bean Operation

Chethan Kumar Baliga
Greenhorn

Joined: Sep 17, 2002
Posts: 11
I am using WebSphere Studio Application Developer (WSAD 5.0).
My Application has Stateless Session Beans. These Beans call Data Access Objects (DAOs) for Database Operations (DB used is Oracle 8). In a particular bean's method, the Database operations to be done are huge and take some time in minutes (large no. of record updates).
However after 120 seconds, the WSAD server console gives a message saying
"Transaction XXXXXXX has timed out after 120 seconds"
which leaves the Bean operation incomplete.
The Session Bean used is Stateless and has Container Managed Transaction.
Is 120 seconds the default value for Container Managed Transaction to timeout?
Is this value configurable?
Please advice.
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
Yes, the transaction timeout is editable within WSAD, but only by using the WebSphere Administration console. In WSAD, pick your WebSphere server and make sure the "Enable Administration console" box is checked. Then start your server. Then open a browser and type http://localhost:9090/admin to open the admin console.
In the Admin console, pick the Servers tree and select your application server. In the Application Servers page for your server, pick the "Transaction Service" under "Additional Properties". On this page you can change the transaction timeout from the default (120 seconds) to a larger value. Make sure you press "Apply" and also that you Save your application server configuration.
You will then probably get a notice in WSAD indicating that your server has changed. Accept the changes.
Kyle


Kyle Brown, Author of Persistence in the Enterprise and Enterprise Java Programming with IBM Websphere, 2nd Edition
See my homepage at http://www.kyle-brown.com/ for other WebSphere information.
Chethan Kumar Baliga
Greenhorn

Joined: Sep 17, 2002
Posts: 11
Hey Kyle!
That was very prompt. And which is why I was wondering, where the Configuration parameter was. No doubt, I could not find it in WSAD Server Configuration. :-) Excellent directions, thanks!
I am now able to configure the time out.
Thanks, once again...
Chethan.
fred sword
Greenhorn

Joined: Oct 18, 2004
Posts: 1
Hi Kyle,

We are running IBM WebSphere Application Server for Network Deployment 5.1.0.1 (Build Number: cf10406.04, Build Date: 02/10/2004) and we have the same problem as described at http://www-1.ibm.com/support/docview.wss?rs=180&context=SSEQTP&uid=swg1PQ72575

We get the transaction timeout message in the log
[10/18/04 14:11:02:729 EDT] 4bfd76cd TimeoutManage I WTRN0006W: Transaction 57415344:000000000000026f00000001d19858cf914fd558ac48b08499a1b7674c4a5331617349636973[] has timed out after 120 seconds.


but there is no Exception thrown.

Isn't WebSphere supposed to throw a TransactionRolledBackException or something when there's a transaction timeout ?

TIA
[ October 18, 2004: Message edited by: fred sword ]
rvakella akella
Greenhorn

Joined: Jul 13, 2006
Posts: 1
Go to the server perspective.
Double click there
On the configuration page choose EJB
Set your timeout value there
vishalp patel
Greenhorn

Joined: May 28, 2008
Posts: 1
I am using IBM Rational Application Developer 7.0 and I have tried all above solution but it doesn't work for me.

could you please help me out I am getting same error every time i ma starting my application server in debug mode.

Regards,
vishal
Romulo F. Freitas
Greenhorn

Joined: Jun 10, 2009
Posts: 2
Kyle

Thank you so much !
This is the fastest and easiest solution i've ever found for a not usual problem.
Great ³ !!!
Munish K Singh
Greenhorn

Joined: Mar 10, 2004
Posts: 2
If you are using that server instance only to perform one particular operation then it is good to increase the timeout at server level,

Alternatively you can use the below transaction management annotation at bean level.
@TransactionManagement(TransactionManagementType.BEAN)

Matheus Mendes
Ranch Hand

Joined: May 15, 2007
Posts: 66
Hi Guys !

I'm facing the same problem in the Websphere AS. Is there any other way to solve this problem? I'm asking because my environment don't allows this kind of modification(alter the server configuration), so I would to know if any of you knows any other solution.

I'm processing a file that have around 5000 records to insert into my database and I'm getting time out when the inserts still running.

Thank you guys,

cya.


The Death of one is a tragedy, but the Death of a million is just a statistic. Joseph Stalin

SCJP 6.0, SCJD
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Transaction Times Out after 120 seconds in Session Bean Operation