my dog learned polymorphism*
The moose likes Websphere and the fly likes Problem starting WTE in WSAD 5.0.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Problem starting WTE in WSAD 5.0.1" Watch "Problem starting WTE in WSAD 5.0.1" New topic
Author

Problem starting WTE in WSAD 5.0.1

Anneke Perelaer
Greenhorn

Joined: Jun 18, 2003
Posts: 4
Help!!!
When starting the server in WSAD I get the following error:
java.io.IOException: Can't connect at
com.ibm.etools.websphere.tools.runner.CommonServerRunner$Communicator.run
CommonServerRunner.java:116) at java.lang.Thread.run(Thread.java:512)
Does anyone have a clue?
It already has taking me hours of trying different scenarios. I guess (but it is nothing more than a guess) that it has something to do with my datasource so I checked it (jndi name for instance is correct). I can connect to the database I need when using de Data Perspective. I use a DB2 UDB 7.2-database. At first I had problems with my datasource because I didn't run C:\Program Files\SQLLIB\java12\usejdbc2.bat.
I had problems that concerned a double 'jdbc' in the dataource-jndi-name (I
named it jdbc/myDataSource, but WSAD searched for jdbc/jdbc/myDataSource).
Now I do not see that problem in my console anymore, but I'm now confronted
with the error above.
Please please please help me
In advance: thanks!
Anneke Perelaer
mohd. gulrez khan
Greenhorn

Joined: Nov 23, 2004
Posts: 20
Hey ,

M getting this error too ,Does anyone know why this error occurs.

the complete stack trace is as follows :

*** Starting the server ***
************ Start Display Current Environment ************
WebSphere Platform 5.1 [BASE 5.1.0.3 cf30412.02] [JDK 1.4.1 b0344.02] running with process name localhost\localhost\server1 and process id 2924
Host Operating System is Windows XP, version 5.1
Java version = J2RE 1.4.1 IBM Windows 32 build cn1411-20031011 (JIT enabled: jitc), Java Compiler = jitc, Java VM name = Classic VM
was.install.root = C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51
user.install.root = C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51
Java Home = C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51\java\jre
ws.ext.dirs = C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/java/lib;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/classes;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/classes;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/lib;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/lib/ext;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/web/help;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/deploytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime;C:/Program Files/IBM/WebSphere Studio/Application Developer/v5.1.2/wstools/eclipse/plugins/com.ibm.etools.webservice_5.1.2/runtime/worf.jar
Classpath = C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/properties;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/properties;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/lib/bootstrap.jar;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/lib/j2ee.jar;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/lib/lmproxy.jar;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/lib/urlprotocols.jar;C:/Program Files/IBM/WebSphere Studio/Application Developer/v5.1.2/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.1.1.1/runtime/wteServers.jar;C:/Program Files/IBM/WebSphere Studio/Application Developer/v5.1.2/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.1.1.1/runtime/wasToolsCommon.jar
Java Library path = C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/bin;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/java/bin;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51/java/jre/bin;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\eclipse\jre\bin;.;C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\eclipse\jre\bin;C:\oracle\ora92\bin;C:\j2sdk1.4.1_01\bin;C:\Program Files\Oracle\jre\1.1.8\bin;C:\Program Files\Oracle\jre\1.3.1\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\IBM\Infoprint Select;C:\Utilities;C:\Notes;C:\Program Files\XLView\;C:\lotus\compnent\;C:\Program Files\IBM\Personal Communications\;C:\Program Files\IBM\Trace Facility\;C:\WINDOWS\Downloaded Program Files;C:\Infoprint;
************* End Display Current Environment *************
[5/12/06 12:04:09:753 IST] 3e461197 ManagerAdmin I TRAS0017I: The startup trace state is *=all=disabled.
[5/12/06 12:04:10:725 IST] 3e461197 AdminInitiali A ADMN0015I: AdminService initialized
[5/12/06 12:04:12:227 IST] 3e461197 Configuration A SECJ0215I: Successfully set JAAS login provider configuration class to com.ibm.ws.security.auth.login.Configuration.
[5/12/06 12:04:12:277 IST] 3e461197 SecurityDM I SECJ0231I: The Security component's FFDC Diagnostic Module com.ibm.ws.security.core.SecurityDM registered successfully: true.
[5/12/06 12:04:12:707 IST] 3e461197 SecurityCompo I SECJ0309I: Java 2 Security is disabled.
[5/12/06 12:04:12:717 IST] 3e461197 SecurityCompo I SECJ0212I: WCCM JAAS configuration information successfully pushed to login provider class.
[5/12/06 12:04:12:727 IST] 3e461197 SecurityCompo I SECJ0240I: Security service initialization completed successfully
[5/12/06 12:04:12:737 IST] 3e461197 JMSRegistrati A MSGS0602I: WebSphere Embedded Messaging Client only has been installed
[5/12/06 12:04:16:022 IST] 3e461197 CacheServiceI I DYNA0048I: WebSphere Dynamic Cache initialized successfully.
[5/12/06 12:04:17:985 IST] 3e461197 JMXSoapAdapte A ADMC0013I: SOAP connector available at port 8880
[5/12/06 12:04:17:995 IST] 3e461197 SecurityCompo I SECJ0243I: Security service started successfully
[5/12/06 12:04:18:005 IST] 3e461197 SecurityCompo I SECJ0210I: Security enabled false
[5/12/06 12:04:19:197 IST] 3e461197 ApplicationMg A WSVR0200I: Starting application: IBMUTC
[5/12/06 12:04:19:407 IST] 3e461197 WebContainer A SRVE0161I: IBM WebSphere Application Server - Web Container. Copyright IBM Corp. 1998-2002
[5/12/06 12:04:19:427 IST] 3e461197 WebContainer A SRVE0162I: Servlet Specification Level: 2.3
[5/12/06 12:04:19:437 IST] 3e461197 WebContainer A SRVE0163I: Supported JSP Specification Level: 1.2
[5/12/06 12:04:19:557 IST] 3e461197 WebContainer A SRVE0169I: Loading Web Module: IBM Universal Test Client.
[5/12/06 12:04:19:848 IST] 3e461197 WebGroup I SRVE0180I: [IBM Universal Test Client] [/UTC] [Servlet.LOG]: JSP 1.2 Processor: init
[5/12/06 12:04:19:958 IST] 3e461197 WebGroup I SRVE0180I: [IBM Universal Test Client] [/UTC] [Servlet.LOG]: SimpleFileServlet: init
[5/12/06 12:04:20:058 IST] 3e461197 ApplicationMg A WSVR0221I: Application started: IBMUTC
[5/12/06 12:04:20:058 IST] 3e461197 ApplicationMg A WSVR0200I: Starting application: DefaultEAR
[5/12/06 12:04:20:078 IST] 3e461197 WebContainer A SRVE0169I: Loading Web Module: MyApplication.
[5/12/06 12:04:20:168 IST] 3e461197 WebGroup I SRVE0180I: [MyApplication] [/MyApplication] [Servlet.LOG]: JSP 1.2 Processor: init
[5/12/06 12:04:20:238 IST] 3e461197 WebGroup I SRVE0180I: [MyApplication] [/MyApplication] [Servlet.LOG]: SimpleFileServlet: init
[5/12/06 12:04:20:258 IST] 3e461197 WebGroup I SRVE0180I: [MyApplication] [/MyApplication] [Servlet.LOG]: InvokerServlet: init
[5/12/06 12:04:20:278 IST] 3e461197 ApplicationMg A WSVR0221I: Application started: DefaultEAR
[5/12/06 12:04:20:378 IST] 3e461197 HttpTransport A SRVE0171I: Transport http is listening on port 9,080.
[5/12/06 12:04:21:780 IST] 3e461197 HttpTransport A SRVE0171I: Transport https is listening on port 9,443.
[5/12/06 12:04:21:821 IST] 3e461197 RMIConnectorC A ADMC0026I: RMI Connector available at port 2809
[5/12/06 12:04:21:901 IST] 3e461197 WsServer A WSVR0001I: Server server1 open for e-business
[5/12/06 12:04:33:958 IST] 3e459197 SystemErr R java.io.IOException: Can't connect
[5/12/06 12:04:33:958 IST] 3e459197 SystemErr R at com.ibm.etools.websphere.tools.runner.CommonServerRunner$Communicator.run(CommonServerRunner.java:116)
[5/12/06 12:04:33:958 IST] 3e459197 SystemErr R at java.lang.Thread.run(Thread.java:568)



Thanks in advance


Gulrez<br /> <br />SCJP 1.4 , SCWCD 1.4.<br />SCBCD 1.3
Anneke Perelaer
Greenhorn

Joined: Jun 18, 2003
Posts: 4
Hello,
It sure was a while ago when I encountered this problem, but I remember it had something to do with my firewall. When I closed down my firewall the problem was gone. Not a nice solution, but it was good enough for me at the time, because I was trying out things at home. I didn't look any further.
Hope this will set you on the (hopefully) right path!
Bye,
Anneke Perelaer
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem starting WTE in WSAD 5.0.1